The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and…
Priority MEDIUM 44CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
The validateSignature method in the SAML2\Utils class in SimpleSAMLphp before 1.14.10 and simplesamlphp/saml2 library before 1.9.1, 1.10.x before 1.10.3, and 2.x before 2.3.3 allows remote attackers to spoof SAML responses or possibly cause a denial of service (memory consumption) by leveraging improper conversion of return values to boolean.
Why it matters now
EPSS 0.02413 84th percentileScored 2026-11-07
Fix Fixed simplesamlphp/saml2 (Packagist): 1.10.3, 1.8.1, 1.9.1 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | simplesamlphp/saml2 (Packagist) | 1.10 to before 1.10.3 | 1.10.3 | Patch available | GHSA-r8v4-7vwj-983x |
| — | simplesamlphp/saml2 (Packagist) | before 1.8.1 | 1.8.1 | Patch available | GHSA-r8v4-7vwj-983x |
| — | simplesamlphp/saml2 (Packagist) | 1.9.0 to before 1.9.1 | 1.9.1 | Patch available | GHSA-r8v4-7vwj-983x |
| — | simplesamlphp/saml2 (Packagist) | 2.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-r8v4-7vwj-983x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- simplesamlphp/saml2 (Packagist) Vendor— Affected 1.10 to before 1.10.3 Fixed in 1.10.3 Patch available GHSA-r8v4-7vwj-983x
- simplesamlphp/saml2 (Packagist) Vendor— Affected before 1.8.1 Fixed in 1.8.1 Patch available GHSA-r8v4-7vwj-983x
- simplesamlphp/saml2 (Packagist) Vendor— Affected 1.9.0 to before 1.9.1 Fixed in 1.9.1 Patch available GHSA-r8v4-7vwj-983x
- simplesamlphp/saml2 (Packagist) Vendor— Affected 2.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-r8v4-7vwj-983x
CPE configurations NVD · 13
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* | up to 1.14.9 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:simplesamlphp:1.10:*:*:*:*:*:*:* | 1.10 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* | up to 1.9 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:1.10:*:*:*:*:*:*:* | 1.10 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:1.10.1:*:*:*:*:*:*:* | 1.10.1 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:1.10.2:*:*:*:*:*:*:* | 1.10.2 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:2.0.0:*:*:*:*:*:*:* | 2.0.0 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:2.0.1:*:*:*:*:*:*:* | 2.0.1 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:2.1:*:*:*:*:*:*:* | 2.1 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:2.2:*:*:*:*:*:*:* | 2.2 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:simplesamlphp:*:*:*:*:*:*:*:* Versions up to 1.14.9 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:simplesamlphp:1.10:*:*:*:*:*:*:* Versions 1.10 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:*:*:*:*:*:*:*:* Versions up to 1.9 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:1.10:*:*:*:*:*:*:* Versions 1.10 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:1.10.1:*:*:*:*:*:*:* Versions 1.10.1 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:1.10.2:*:*:*:*:*:*:* Versions 1.10.2 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:2.0.0:*:*:*:*:*:*:* Versions 2.0.0 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:2.0.1:*:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:2.1:*:*:*:*:*:*:* Versions 2.1 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:2.2:*:*:*:*:*:*:* Versions 2.2 Vulnerable ·simplesamlphp
Show 3 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:simplesamlphp:saml2:2.3:*:*:*:*:*:*:* | 2.3 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:2.3.1:*:*:*:*:*:*:* | 2.3.1 | Vulnerable | simplesamlphp |
| cpe:2.3:a:simplesamlphp:saml2:2.3.2:*:*:*:*:*:*:* | 2.3.2 | Vulnerable | simplesamlphp |
- cpe:2.3:a:simplesamlphp:saml2:2.3:*:*:*:*:*:*:* Versions 2.3 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:2.3.1:*:*:*:*:*:*:* Versions 2.3.1 Vulnerable ·simplesamlphp
- cpe:2.3:a:simplesamlphp:saml2:2.3.2:*:*:*:*:*:*:* Versions 2.3.2 Vulnerable ·simplesamlphp
Remediation
- Fix · GHSA-r8v4-7vwj-983x simplesamlphp/saml2 (Packagist) Fixed in 1.10.3 Advisory →
- Fix · GHSA-r8v4-7vwj-983x simplesamlphp/saml2 (Packagist) Fixed in 1.8.1 Advisory →
- Fix · GHSA-r8v4-7vwj-983x simplesamlphp/saml2 (Packagist) Fixed in 1.9.1 Advisory →
- Fix · GHSA-r8v4-7vwj-983x simplesamlphp/saml2 (Packagist) Fixed in 2.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2016-9814
- 2026-10-03 Alias added: GHSA-r8v4-7vwj-983x
References
Advisory 2
More simplesamlphp Saml2 vulnerabilities
- TI-2018-05557 HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect… CVSS 3.0HIGH 8.1
- TI-2018-04799 The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp… CVSS 3.0HIGH 7.5
- TI-2023-26752 Validation of SignedInfo CVSS 3.1HIGH 7.5
Sources
- CVE-2016-9814 · CVE Program
- CVE-2016-9814 · NVD
- FIRST EPSS
- GHSA-r8v4-7vwj-983x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences