Moodle 3.x has user fullname disclosure on the user preferences page.
Priority LOW 31CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Moodle 3.x has user fullname disclosure on the user preferences page.
Why it matters now
EPSS 0.01242 69th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.1.7, 3.2.4, 3.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.1 to before 3.1.7 | 3.1.7 | Patch available | GHSA-54r2-r67g-fr9m |
| — | moodle/moodle (Packagist) | 3.2 to before 3.2.4 | 3.2.4 | Patch available | GHSA-54r2-r67g-fr9m |
| — | moodle/moodle (Packagist) | 3.3 to before 3.3.1 | 3.3.1 | Patch available | GHSA-54r2-r67g-fr9m |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.7 Fixed in 3.1.7 Patch available GHSA-54r2-r67g-fr9m
- moodle/moodle (Packagist) Vendor— Affected 3.2 to before 3.2.4 Fixed in 3.2.4 Patch available GHSA-54r2-r67g-fr9m
- moodle/moodle (Packagist) Vendor— Affected 3.3 to before 3.3.1 Fixed in 3.3.1 Patch available GHSA-54r2-r67g-fr9m
CPE configurations NVD · 22
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.0:beta:*:*:*:*:*:* | 3.1.0 beta | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.0:rc1:*:*:*:*:*:* | 3.1.0 rc1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.0:rc2:*:*:*:*:*:* | 3.1.0 rc2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.1:*:*:*:*:*:*:* | 3.1.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.2:*:*:*:*:*:*:* | 3.1.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.3:*:*:*:*:*:*:* | 3.1.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.4:*:*:*:*:*:*:* | 3.1.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.5:*:*:*:*:*:*:* | 3.1.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.1.6:*:*:*:*:*:*:* | 3.1.6 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.0:beta:*:*:*:*:*:* Versions 3.1.0 beta Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.0:rc1:*:*:*:*:*:* Versions 3.1.0 rc1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.0:rc2:*:*:*:*:*:* Versions 3.1.0 rc2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.2:*:*:*:*:*:*:* Versions 3.1.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.3:*:*:*:*:*:*:* Versions 3.1.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.4:*:*:*:*:*:*:* Versions 3.1.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.5:*:*:*:*:*:*:* Versions 3.1.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.1.6:*:*:*:*:*:*:* Versions 3.1.6 Vulnerable ·Moodle
Show 12 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.0:beta:*:*:*:*:*:* | 3.2.0 beta | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.0:rc1:*:*:*:*:*:* | 3.2.0 rc1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.0:rc2:*:*:*:*:*:* | 3.2.0 rc2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.0:rc3:*:*:*:*:*:* | 3.2.0 rc3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.0:rc4:*:*:*:*:*:* | 3.2.0 rc4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.0:rc5:*:*:*:*:*:* | 3.2.0 rc5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.2:*:*:*:*:*:*:* | 3.2.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.3:*:*:*:*:*:*:* | 3.2.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.3.0:*:*:*:*:*:*:* | 3.3.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.3.1:*:*:*:*:*:*:* | 3.3.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.0:beta:*:*:*:*:*:* Versions 3.2.0 beta Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.0:rc1:*:*:*:*:*:* Versions 3.2.0 rc1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.0:rc2:*:*:*:*:*:* Versions 3.2.0 rc2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.0:rc3:*:*:*:*:*:* Versions 3.2.0 rc3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.0:rc4:*:*:*:*:*:* Versions 3.2.0 rc4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.0:rc5:*:*:*:*:*:* Versions 3.2.0 rc5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.2:*:*:*:*:*:*:* Versions 3.2.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.3:*:*:*:*:*:*:* Versions 3.2.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.3.0:*:*:*:*:*:*:* Versions 3.3.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-54r2-r67g-fr9m moodle/moodle (Packagist) Fixed in 3.1.7 Advisory →
- Fix · GHSA-54r2-r67g-fr9m moodle/moodle (Packagist) Fixed in 3.2.4 Advisory →
- Fix · GHSA-54r2-r67g-fr9m moodle/moodle (Packagist) Fixed in 3.3.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-2642
- 2026-10-03 Alias added: GHSA-54r2-r67g-fr9m
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2017-2642 · CVE Program
- CVE-2017-2642 · NVD
- FIRST EPSS
- GHSA-54r2-r67g-fr9m · GitHub Advisory Database · CC BY 4.0
- CVE-2017-2642 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences