Read the docs
TI-2017-01895 Aliases CVE-2017-2645GHSA-9cg4-4f87-jhm3

In Moodle 3.x, XSS can occur via attachments to evidence of prior learning.

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

In Moodle 3.x, XSS can occur via attachments to evidence of prior learning.

Why it matters now

EPSS 0.01054 64th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.1.5, 3.2.2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Moodle 3.xMoodle 3.x—No fix listedCNA
—moodle/moodle (Packagist)3.1 to before 3.1.53.1.5Patch availableGHSA-9cg4-4f87-jhm3
—moodle/moodle (Packagist)3.2 to before 3.2.23.2.2Patch availableGHSA-9cg4-4f87-jhm3
  • Moodle 3.x Vendor— Affected Moodle 3.x Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.5 Fixed in 3.1.5 Patch available GHSA-9cg4-4f87-jhm3
  • moodle/moodle (Packagist) Vendor— Affected 3.2 to before 3.2.2 Fixed in 3.2.2 Patch available GHSA-9cg4-4f87-jhm3

CPE configurations NVD · 16

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:*3.1.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.1.0:beta:*:*:*:*:*:*3.1.0 betaVulnerableMoodle
cpe:2.3:a:moodle:moodle:3.1.0:rc1:*:*:*:*:*:*3.1.0 rc1VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.1.0:rc2:*:*:*:*:*:*3.1.0 rc2VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.1.1:*:*:*:*:*:*:*3.1.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.1.2:*:*:*:*:*:*:*3.1.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.1.3:*:*:*:*:*:*:*3.1.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.1.4:*:*:*:*:*:*:*3.1.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:*3.2.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.0:beta:*:*:*:*:*:*3.2.0 betaVulnerableMoodle
  • cpe:2.3:a:moodle:moodle:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.1.0:beta:*:*:*:*:*:* Versions 3.1.0 beta Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.1.0:rc1:*:*:*:*:*:* Versions 3.1.0 rc1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.1.0:rc2:*:*:*:*:*:* Versions 3.1.0 rc2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.1.2:*:*:*:*:*:*:* Versions 3.1.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.1.3:*:*:*:*:*:*:* Versions 3.1.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.1.4:*:*:*:*:*:*:* Versions 3.1.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.0:beta:*:*:*:*:*:* Versions 3.2.0 beta Vulnerable ·Moodle
Show 6 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:3.2.0:rc1:*:*:*:*:*:*3.2.0 rc1VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.0:rc2:*:*:*:*:*:*3.2.0 rc2VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.0:rc3:*:*:*:*:*:*3.2.0 rc3VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.0:rc4:*:*:*:*:*:*3.2.0 rc4VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.0:rc5:*:*:*:*:*:*3.2.0 rc5VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:*3.2.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:3.2.0:rc1:*:*:*:*:*:* Versions 3.2.0 rc1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.0:rc2:*:*:*:*:*:* Versions 3.2.0 rc2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.0:rc3:*:*:*:*:*:* Versions 3.2.0 rc3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.0:rc4:*:*:*:*:*:* Versions 3.2.0 rc4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.0:rc5:*:*:*:*:*:* Versions 3.2.0 rc5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-9cg4-4f87-jhm3 moodle/moodle (Packagist) Fixed in 3.1.5 Advisory →
  • Fix · GHSA-9cg4-4f87-jhm3 moodle/moodle (Packagist) Fixed in 3.2.2 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-2645
  2. 2026-10-03 Alias added: GHSA-9cg4-4f87-jhm3

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources