In Moodle 3.3, the course overview block reveals activities in hidden courses.
Priority LOW 22CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
In Moodle 3.3, the course overview block reveals activities in hidden courses.
Why it matters now
EPSS 0.00907 60th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.3.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | before 3.3.1 | 3.3.1 | Patch available | GHSA-w2pj-r8m3-r4jc |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected before 3.3.1 Fixed in 3.3.1 Patch available GHSA-w2pj-r8m3-r4jc
Remediation
- Fix · GHSA-w2pj-r8m3-r4jc moodle/moodle (Packagist) Fixed in 3.3.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-7531
- 2026-10-03 Alias added: GHSA-w2pj-r8m3-r4jc
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2017-7531 · CVE Program
- CVE-2017-7531 · NVD
- FIRST EPSS
- GHSA-w2pj-r8m3-r4jc · GitHub Advisory Database · CC BY 4.0
- CVE-2017-7531 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences