Craft CMS before 2.6.2976 does not properly restrict viewing the contents of files in the craft/app/ folder.
Priority LOW 26CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Craft CMS before 2.6.2976 does not properly restrict viewing the contents of files in the craft/app/ folder.
Why it matters now
EPSS 0.01153 67th percentileScored 2026-11-07
Fix Fixed craftcms/cms (Packagist): 2.6.2976
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | craftcms/cms (Packagist) | before 2.6.2976 | 2.6.2976 | Patch available | GHSA-7qq6-fgpw-xw45 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- craftcms/cms (Packagist) Vendor— Affected before 2.6.2976 Fixed in 2.6.2976 Patch available GHSA-7qq6-fgpw-xw45
Remediation
- Fix · GHSA-7qq6-fgpw-xw45 craftcms/cms (Packagist) Fixed in 2.6.2976 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-8383
- 2026-10-03 Alias added: GHSA-7qq6-fgpw-xw45
References
More Craft Cms vulnerabilities
- TI-2025-23503 Craft CMS Allows Remote Code Execution KEVCVSS 3.1CRITICAL 10.0
- TI-2024-37138 RCE when PHP `register_argc_argv` config setting is enabled in craftcms/cms KEVCVSS 4.0CRITICAL 9.3
- TI-2025-16994 Potential RCE with a compromised security key in craft/cms KEVCVSS 3.1HIGH 8.1
- TI-2025-24595 Craft CMS stores user-provided content in session files KEVCVSS 4.0MEDIUM 6.9
- TI-2023-22284 Craft CMS Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2024-25171 Craft CMS up to v3.7.31 was discovered to contain a SQL injection vulnerability via the GraphQL API endpoint. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2017-8383 · CVE Program
- CVE-2017-8383 · NVD
- FIRST EPSS
- GHSA-7qq6-fgpw-xw45 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences