Improper authentication in Apache Kafka
Priority LOW 35CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.
Summary
In Apache Kafka 0.10.0.0 to 0.10.2.1 and 0.11.0.0 to 0.11.0.1, authenticated Kafka clients may use impersonation via a manually crafted protocol message with SASL/PLAIN or SASL/SCRAM authentication when using the built-in PLAIN or SCRAM server implementations in Apache Kafka.
Why it matters now
EPSS 0.02872 86th percentileScored 2026-11-07
Fix Partial org.apache.kafka:kafka-clients (Maven): 0.10.2.2, 0.11.0.2Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Kafka | 0.10.0.0 to 0.10.2.1; 0.11.0.0 to 0.11.0.1 | — | No fix listed | CNA |
| — | org.apache.kafka:kafka-clients (Maven) | 0.10.0.0 to before 0.10.2.2 | 0.10.2.2 | Patch available | GHSA-xm78-4m3g-7wm7 |
| — | org.apache.kafka:kafka-clients (Maven) | 0.11.0.0 to before 0.11.0.2 | 0.11.0.2 | Patch available | GHSA-xm78-4m3g-7wm7 |
- Apache Kafka VendorApache Affected 0.10.0.0 to 0.10.2.1; 0.11.0.0 to 0.11.0.1 Fixed in — No fix listed CNA
- org.apache.kafka:kafka-clients (Maven) Vendor— Affected 0.10.0.0 to before 0.10.2.2 Fixed in 0.10.2.2 Patch available GHSA-xm78-4m3g-7wm7
- org.apache.kafka:kafka-clients (Maven) Vendor— Affected 0.11.0.0 to before 0.11.0.2 Fixed in 0.11.0.2 Patch available GHSA-xm78-4m3g-7wm7
Remediation
- Fix · GHSA-xm78-4m3g-7wm7 org.apache.kafka:kafka-clients (Maven) Fixed in 0.10.2.2 Advisory →
- Fix · GHSA-xm78-4m3g-7wm7 org.apache.kafka:kafka-clients (Maven) Fixed in 0.11.0.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat JBoss Fuse 6 | Affected | No fix planned: Will not fix |
Not affected: 3 products
- Red Hat Fuse 7
- Red Hat Mobile Application Platform 4
- Red Hat OpenShift Application Runtimes
Timeline
- 2026-10-02 Threatist record created from CVE-2017-12610
- 2026-10-03 Alias added: GHSA-xm78-4m3g-7wm7
References
Other 9
- [kafka-users] 20180726 CVE-2017-12610: Authenticated Kafka clients may impersonate other users
- [drill-dev] 20191017 Dependencies used by Drill contain known vulnerabilities
- [drill-dev] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
- [drill-issues] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
- https://www.oracle.com/security-alerts/cpujul2020.html
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/b6157be1a09df332294213bd21e90dcf9fe4c1810193be54620e4210@%3Cusers.kafka.apache.org%3E
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E
More Apache Kafka vulnerabilities
- TI-2025-20589 Apache Kafka Client: Arbitrary file read and SSRF vulnerability CVSS 3.1HIGH 7.5
- TI-2026-25947 Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication CVSS 3.1CRITICAL 9.1
- TI-2018-12295 Improper input validation in Apache Kafka CVSS 3.0HIGH 8.8
- TI-2025-20590 Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration CVSS 3.1HIGH 8.8
- TI-2022-15706 Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers CVSS 3.1HIGH 7.5
- TI-2025-20591 Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration CVSS 3.1HIGH 7.5
Sources
- CVE-2017-12610 · CVE Program
- CVE-2017-12610 · NVD
- FIRST EPSS
- GHSA-xm78-4m3g-7wm7 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-12610 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences