Stack-based buffer overflow in Qemu
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 6 fixed, 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-121 and the CVSS impact.
Summary
A stack-based buffer overflow vulnerability was found in NBD server implementation in qemu before 2.11 allowing a client to request an export name of size up to 4096 bytes, which in fact should be limited to 256 bytes, causing an out-of-bounds stack write in the qemu process. If NBD server requires TLS, the attacker cannot trigger the buffer overflow without first successfully negotiating TLS.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| QEMU | Qemu | 2.11 | — | No fix listed | CNA |
- Qemu VendorQEMU Affected 2.11 Fixed in — No fix listed CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* | before 2.11 | Vulnerable | QEMU |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* | 17.10 | Vulnerable | Canonical |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
- cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* Versions before 2.11 Vulnerable ·QEMU
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:* Versions 17.10 Vulnerable ·Canonical
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
Remediation
Red Hat 2 advisories
- RHSA-2018:1113 Released 2018-04-11 · Red Hat rating Moderateqemu-kvm-rhev security and bug fix update
- Red Hat OpenStack Platform 10.0 qemu-img-rhev-10:2.10.0-21.el7, qemu-kvm-common-rhev-10:2.10.0-21.el7, qemu-kvm-rhev-10:2.10.0-21.el7 +1
- Red Hat OpenStack Platform 11.0 qemu-img-rhev-10:2.10.0-21.el7, qemu-kvm-common-rhev-10:2.10.0-21.el7, qemu-kvm-rhev-10:2.10.0-21.el7 +1
- Red Hat OpenStack Platform 12.0 qemu-img-rhev-10:2.10.0-21.el7, qemu-kvm-common-rhev-10:2.10.0-21.el7, qemu-kvm-rhev-10:2.10.0-21.el7 +1
- Red Hat OpenStack Platform 8.0 (Liberty) qemu-img-rhev-10:2.10.0-21.el7, qemu-kvm-common-rhev-10:2.10.0-21.el7, qemu-kvm-rhev-10:2.10.0-21.el7 +1
- Red Hat OpenStack Platform 9.0 qemu-img-rhev-10:2.10.0-21.el7, qemu-kvm-common-rhev-10:2.10.0-21.el7, qemu-kvm-rhev-10:2.10.0-21.el7 +1
- RHSA-2018:1104 Released 2018-04-10 · Red Hat rating Importantqemu-kvm-rhev security, bug fix, and enhancement update
- Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts qemu-img-rhev-10:2.10.0-21.el7, qemu-kvm-common-rhev-10:2.10.0-21.el7, qemu-kvm-rhev-10:2.10.0-21.el7 +1
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix yet |
| Red Hat OpenStack Platform 10.0 | Fixed | RHSA-2018:1113 |
| Red Hat OpenStack Platform 11.0 | Fixed | RHSA-2018:1113 |
| Red Hat OpenStack Platform 12.0 | Fixed | RHSA-2018:1113 |
| Red Hat OpenStack Platform 8.0 (Liberty) | Fixed | RHSA-2018:1113 |
| Red Hat OpenStack Platform 9.0 | Fixed | RHSA-2018:1113 |
| Red Hat Virtualization 4 Management Agent for RHEL 7 Hosts | Fixed | RHSA-2018:1104 |
Not affected: 6 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
- Red Hat Enterprise Linux OpenStack Platform 7 (Kilo)
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15118
- 2026-10-03 Alias added: GHSA-p8q8-xqgv-rwvr
References
More Qemu vulnerabilities
- TI-2024-16148 QEMU before 8.2.0 has an integer underflow, and resultant buffer overflow, via a TI… CVSS 3.1HIGH 8.8
- TI-2022-02736 Uncontrolled resource consumption in QEMU CVSS 3.1HIGH 7.8
- TI-2023-02681 Qemu: 9pfs: improper access control on special files CVSS 3.1HIGH 7.1
- TI-2019-09678 The QMP migrate command in QEMU version 4.0.0 and earlier is vulnerable to OS command… CVSS 3.0CRITICAL 9.8
- TI-2024-03326 Qemu-kvm: net: assertion failure in update_sctp_checksum() CVSS 3.1MEDIUM 5.5
- TI-2023-22631 QEMU through 8.0.0 could trigger a division by zero in scsi_disk_reset in… CVSS 3.1MEDIUM 5.5
Sources
- CVE-2017-15118 · CVE Program
- CVE-2017-15118 · NVD
- FIRST EPSS
- GHSA-p8q8-xqgv-rwvr · GitHub Advisory Database · CC BY 4.0
- CVE-2017-15118 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences