Improper input validation in Apache SpamAssassin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 4 fixed, 2 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and Red Hat.
Summary
A denial of service vulnerability was identified that exists in Apache SpamAssassin before 3.4.2. The vulnerability arises with certain unclosed tags in emails that cause markup to be handled incorrectly leading to scan timeouts. In Apache SpamAssassin, using HTML::Parser, we setup an object and hook into the begin and end tag event handlers In both cases, the "open" event is immediately followed by a "close" event - even if the tag *does not* close in the HTML being parsed. Because of this, we are missing the "text" event to deal with the object normally. This can cause carefully crafted emails that might take more scan time than expected leading to a Denial of Service. The issue is possibly a bug or design decision in HTML::Parser that specifically impacts the way Apache SpamAssassin uses the module with poorly formed html. The exploit has been seen in the wild but not believed to have been purposefully part of a Denial of Service attempt. We are concerned that there may be attempts to abuse the vulnerability in the future.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache SpamAssassin | before 3.4.2 | 3.4.2 | Patch available | CNA |
- Apache SpamAssassin VendorApache Affected before 3.4.2 Fixed in 3.4.2 Patch available CNA
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:spamassassin:*:*:*:*:*:*:*:* | before 3.4.2 | Vulnerable | Apache |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* | 16.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* | 18.04 | Vulnerable | Canonical |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_eus:7.5:*:*:*:*:*:*:* | 7.5 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
- cpe:2.3:a:apache:spamassassin:*:*:*:*:*:*:*:* Versions before 3.4.2 Vulnerable ·Apache
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:* Versions 16.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_eus:7.5:*:*:*:*:*:*:* Versions 7.5 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
Remediation
- Fix · CNA Apache SpamAssassin (Apache Software Foundation) Fixed in 3.4.2
Red Hat 1 advisory
- RHSA-2018:2916 Released 2018-10-11 · Red Hat rating Importantspamassassin security update
- Red Hat Enterprise Linux Client Optional (v. 7) spamassassin-3.4.0-4.el7_5
- Red Hat Enterprise Linux Server (v. 7) spamassassin-3.4.0-4.el7_5
- Red Hat Enterprise Linux Workstation (v. 7) spamassassin-3.4.0-4.el7_5
- Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7) spamassassin-3.4.0-4.el7_5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Advisory ·
Apache SpamAssassin — USN-3811-1
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2018-08437 A potential Remote Code Execution bug exists with the PDFInfo plugin in Apache SpamAssassin before 3.4.2.Priority MEDIUM 55
- TI-2018-08438 Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.Priority LOW 36
- Advisory ·
Apache SpamAssassin — RHSA-2018:2916
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2018-08438 Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.Priority LOW 36
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux Client Optional (v. 7) | Fixed | RHSA-2018:2916 |
| Red Hat Enterprise Linux Server (v. 7) | Fixed | RHSA-2018:2916 |
| Red Hat Enterprise Linux Workstation (v. 7) | Fixed | RHSA-2018:2916 |
| Red Hat Enterprise Linux for ARM and IBM Power LE (POWER9) Server (v. 7) | Fixed | RHSA-2018:2916 |
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15705
- 2026-10-03 Alias added: GHSA-m63q-qrvc-wwrm
References
More Apache Spamassassin vulnerabilities
- TI-2006-02383 SpamAssassin before 3.1.3, when running with vpopmail and the paranoid (-P) switch… CVSS 2.0MEDIUM 5.1
- TI-2018-08437 A potential Remote Code Execution bug exists with the PDFInfo plugin in Apache SpamAssassin before 3.4.2. CVSS 3.0CRITICAL 9.8
- TI-2020-01870 Apache SpamAssassin has an OS Command Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2020-01855 OS command injection in Apache SpamAssassin CVSS 3.1HIGH 8.1
- TI-2020-01854 OS command injection in Apache SpamAssassin CVSS 3.1HIGH 8.1
- TI-2019-09265 Uncontrolled resource consumption in Apache SpamAssassin CVSS 3.1HIGH 7.5
Sources
- CVE-2017-15705 · CVE Program
- CVE-2017-15705 · NVD
- FIRST EPSS
- GHSA-m63q-qrvc-wwrm · GitHub Advisory Database · CC BY 4.0
- CVE-2017-15705 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences