Information disclosure in Apache Hadoop
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Vulnerability in Apache Hadoop 0.23.x, 2.x before 2.7.5, 2.8.x before 2.8.3, and 3.0.0-alpha through 3.0.0-beta1 allows a cluster user to expose private files owned by the user running the MapReduce job history server process. The malicious user can construct a configuration file containing XML directives that reference sensitive files on the MapReduce job history server host.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Hadoop | 0.23.0 to 0.23.11; 2.0.0-alpha to 2.8.2; 3.0.0-alpha to 3.0.0-beta1 | — | No fix listed | CNA |
| — | org.apache.hadoop:hadoop-main (Maven) | before 2.7.5 | 2.7.5 | Patch available | GHSA-3v44-382q-55f4 |
| — | org.apache.hadoop:hadoop-main (Maven) | 2.8.0 to before 2.8.3 | 2.8.3 | Patch available | GHSA-3v44-382q-55f4 |
- Apache Hadoop VendorApache Affected 0.23.0 to 0.23.11; 2.0.0-alpha to 2.8.2; 3.0.0-alpha to 3.0.0-beta1 Fixed in — No fix listed CNA
- org.apache.hadoop:hadoop-main (Maven) Vendor— Affected before 2.7.5 Fixed in 2.7.5 Patch available GHSA-3v44-382q-55f4
- org.apache.hadoop:hadoop-main (Maven) Vendor— Affected 2.8.0 to before 2.8.3 Fixed in 2.8.3 Patch available GHSA-3v44-382q-55f4
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:hadoop:*:*:*:*:*:*:*:* | 0.23.0 – 0.23.11; 2.2.0 – 2.8.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.0:alpha:*:*:*:*:*:* | 2.0.0 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.1:alpha:*:*:*:*:*:* | 2.0.1 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.2:alpha:*:*:*:*:*:* | 2.0.2 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.3:alpha:*:*:*:*:*:* | 2.0.3 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.4:alpha:*:*:*:*:*:* | 2.0.4 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.5:alpha:*:*:*:*:*:* | 2.0.5 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.6:alpha:*:*:*:*:*:* | 2.0.6 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.1.0:beta:*:*:*:*:*:* | 2.1.0 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.1.1:beta:*:*:*:*:*:* | 2.1.1 beta | Vulnerable | Apache |
- cpe:2.3:a:apache:hadoop:*:*:*:*:*:*:*:* Versions 0.23.0 – 0.23.11; 2.2.0 – 2.8.2 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.0:alpha:*:*:*:*:*:* Versions 2.0.0 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.1:alpha:*:*:*:*:*:* Versions 2.0.1 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.2:alpha:*:*:*:*:*:* Versions 2.0.2 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.3:alpha:*:*:*:*:*:* Versions 2.0.3 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.4:alpha:*:*:*:*:*:* Versions 2.0.4 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.5:alpha:*:*:*:*:*:* Versions 2.0.5 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.6:alpha:*:*:*:*:*:* Versions 2.0.6 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.1.0:beta:*:*:*:*:*:* Versions 2.1.0 beta Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.1.1:beta:*:*:*:*:*:* Versions 2.1.1 beta Vulnerable ·Apache
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:hadoop:3.0.0:alpha1:*:*:*:*:*:* | 3.0.0 alpha1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha2:*:*:*:*:*:* | 3.0.0 alpha2 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha3:*:*:*:*:*:* | 3.0.0 alpha3 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:alpha4:*:*:*:*:*:* | 3.0.0 alpha4 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:3.0.0:beta1:*:*:*:*:*:* | 3.0.0 beta1 | Vulnerable | Apache |
- cpe:2.3:a:apache:hadoop:3.0.0:alpha1:*:*:*:*:*:* Versions 3.0.0 alpha1 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha2:*:*:*:*:*:* Versions 3.0.0 alpha2 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha3:*:*:*:*:*:* Versions 3.0.0 alpha3 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:alpha4:*:*:*:*:*:* Versions 3.0.0 alpha4 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:3.0.0:beta1:*:*:*:*:*:* Versions 3.0.0 beta1 Vulnerable ·Apache
Remediation
- Fix · GHSA-3v44-382q-55f4 org.apache.hadoop:hadoop-main (Maven) Fixed in 2.7.5 Advisory →
- Fix · GHSA-3v44-382q-55f4 org.apache.hadoop:hadoop-main (Maven) Fixed in 2.8.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2017-15713
- 2026-10-03 Alias added: GHSA-3v44-382q-55f4
References
Advisory 2
More Apache Hadoop vulnerabilities
- TI-2019-12818 Connect2id Nimbus JOSE+JWT before v7.9 can throw various uncaught exceptions while… CVSS 3.1CRITICAL 9.8
- TI-2022-09898 Arbitrary file write in FileUtil#unpackEntries on Windows CVSS 3.1CRITICAL 9.8
- TI-2022-08881 Command injection in org.apache.hadoop.fs.FileUtil.unTarUsingTar CVSS 3.1CRITICAL 9.8
- TI-2021-15353 Heap buffer overflow in libhdfs native library CVSS 3.1CRITICAL 9.8
- TI-2018-05786 Path traversal in Apache Hadoop CVSS 3.0HIGH 8.8
- TI-2017-11489 Information disclosure in Apache Hadoop CVSS 3.0CRITICAL 9.8
Sources
- CVE-2017-15713 · CVE Program
- CVE-2017-15713 · NVD
- FIRST EPSS
- GHSA-3v44-382q-55f4 · GitHub Advisory Database · CC BY 4.0
- CVE-2017-15713 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences