Read the docs
TI-2017-12170 Aliases CVE-2017-16558GHSA-w38g-hj45-mjjp

Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the…

Priority MEDIUM 45CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the back end as well as in the listing module.

Why it matters now

EPSS 0.01506 74th percentileScored 2026-11-07
Fix Fixed contao/contao (Packagist): 4.4.8contao/core-bundle (Packagist): 4.4.8+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—contao/contao (Packagist)3.0.0 – 3.5.30—No fix listedGHSA-w38g-hj45-mjjp
—contao/contao (Packagist)4.0.0 to before 4.4.84.4.8Patch availableGHSA-w38g-hj45-mjjp
—contao/core-bundle (Packagist)4.0.0 to before 4.4.84.4.8Patch availableGHSA-w38g-hj45-mjjp
—contao/listing-bundle (Packagist)4.0.0 to before 4.4.84.4.8Patch availableGHSA-w38g-hj45-mjjp
—contao/core-bundle (Packagist)3.0.0 – 3.5.30—No fix listedGHSA-w38g-hj45-mjjp
—contao/listing-bundle (Packagist)3.0.0 – 3.5.30—No fix listedGHSA-w38g-hj45-mjjp
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • contao/contao (Packagist) Vendor— Affected 3.0.0 – 3.5.30 Fixed in — No fix listed GHSA-w38g-hj45-mjjp
  • contao/contao (Packagist) Vendor— Affected 4.0.0 to before 4.4.8 Fixed in 4.4.8 Patch available GHSA-w38g-hj45-mjjp
  • contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.4.8 Fixed in 4.4.8 Patch available GHSA-w38g-hj45-mjjp
  • contao/listing-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.4.8 Fixed in 4.4.8 Patch available GHSA-w38g-hj45-mjjp
  • contao/core-bundle (Packagist) Vendor— Affected 3.0.0 – 3.5.30 Fixed in — No fix listed GHSA-w38g-hj45-mjjp
  • contao/listing-bundle (Packagist) Vendor— Affected 3.0.0 – 3.5.30 Fixed in — No fix listed GHSA-w38g-hj45-mjjp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:contao:contao_cms:*:*:*:*:*:*:*:*3.0.0 – 3.5.30; 4.0.0 – 4.4.7Vulnerablecontao
  • cpe:2.3:a:contao:contao_cms:*:*:*:*:*:*:*:* Versions 3.0.0 – 3.5.30; 4.0.0 – 4.4.7 Vulnerable ·contao

Remediation

  • Fix · GHSA-w38g-hj45-mjjp contao/contao (Packagist) Fixed in 4.4.8 Advisory →
  • Fix · GHSA-w38g-hj45-mjjp contao/core-bundle (Packagist) Fixed in 4.4.8 Advisory →
  • Fix · GHSA-w38g-hj45-mjjp contao/listing-bundle (Packagist) Fixed in 4.4.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-16558
  2. 2026-10-03 Alias added: GHSA-w38g-hj45-mjjp

References

  • TI-2014-01453 Contao CMS through 3.2.4 has PHP Object Injection Vulnerabilities CVSS 3.1CRITICAL 9.8
  • TI-2019-07939 Contao 4.7 allows Use of a Key Past its Expiration Date. CVSS 3.0CRITICAL 9.8
  • TI-2019-07937 Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password. CVSS 3.0CRITICAL 9.8
  • TI-2017-08073 Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute… CVSS 3.0HIGH 8.8
  • TI-2019-07938 Contao 4.7 allows CSRF. CVSS 3.0HIGH 8.8
  • TI-2012-01169 Multiple cross-site request forgery (CSRF) vulnerabilities in main.php in Contao… CVSS 2.0MEDIUM 6.8
See all 10 →

Sources