Contao 4.7 allows Use of a Key Past its Expiration Date.
Priority MEDIUM 45CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Contao 4.7 allows Use of a Key Past its Expiration Date.
Why it matters now
EPSS 0.01254 69th percentileScored 2026-11-07
Fix Fixed contao/contao (Packagist): 4.7.3contao/core-bundle (Packagist): 4.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | contao/contao (Packagist) | 4.7.0 to before 4.7.3 | 4.7.3 | Patch available | GHSA-j99g-qjvx-995g |
| — | contao/core-bundle (Packagist) | 4.7.0 to before 4.7.3 | 4.7.3 | Patch available | GHSA-j99g-qjvx-995g |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- contao/contao (Packagist) Vendor— Affected 4.7.0 to before 4.7.3 Fixed in 4.7.3 Patch available GHSA-j99g-qjvx-995g
- contao/core-bundle (Packagist) Vendor— Affected 4.7.0 to before 4.7.3 Fixed in 4.7.3 Patch available GHSA-j99g-qjvx-995g
Remediation
- Fix · GHSA-j99g-qjvx-995g contao/contao (Packagist) Fixed in 4.7.3 Advisory →
- Fix · GHSA-j99g-qjvx-995g contao/core-bundle (Packagist) Fixed in 4.7.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2019-10643
- 2026-10-03 Alias added: GHSA-j99g-qjvx-995g
References
Advisory 3
More Contao Cms vulnerabilities
- TI-2014-01453 Contao CMS through 3.2.4 has PHP Object Injection Vulnerabilities CVSS 3.1CRITICAL 9.8
- TI-2019-07937 Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password. CVSS 3.0CRITICAL 9.8
- TI-2017-12170 Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the… CVSS 3.0CRITICAL 9.8
- TI-2017-08073 Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute… CVSS 3.0HIGH 8.8
- TI-2019-07938 Contao 4.7 allows CSRF. CVSS 3.0HIGH 8.8
- TI-2012-01169 Multiple cross-site request forgery (CSRF) vulnerabilities in main.php in Contao… CVSS 2.0MEDIUM 6.8
Sources
- CVE-2019-10643 · CVE Program
- CVE-2019-10643 · NVD
- FIRST EPSS
- GHSA-j99g-qjvx-995g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences