Read the docs
TI-2019-07937 Aliases CVE-2019-10641GHSA-vcgg-hp4r-87gx

Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password.

Priority MEDIUM 45CWE-640Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-640.

Summary

Contao before 3.5.39 and 4.x before 4.7.3 has a Weak Password Recovery Mechanism for a Forgotten Password.

Why it matters now

EPSS 0.0134 71st percentileScored 2026-11-07
Fix Fixed contao/contao (Packagist): 4.4.37, 4.7.3contao/core-bundle (Packagist): 4.4.37, 4.7.3+1 more product

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—contao/contao (Packagist)4.0.0 to before 4.4.374.4.37Patch availableGHSA-vcgg-hp4r-87gx
—contao/contao (Packagist)4.5.0 to before 4.7.34.7.3Patch availableGHSA-vcgg-hp4r-87gx
—contao/core-bundle (Packagist)4.0.0 to before 4.4.374.4.37Patch availableGHSA-vcgg-hp4r-87gx
—contao/core-bundle (Packagist)4.5.0 to before 4.7.34.7.3Patch availableGHSA-vcgg-hp4r-87gx
—contao/core (Packagist)3.0.0 to before 3.5.393.5.39Patch availableGHSA-vcgg-hp4r-87gx
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • contao/contao (Packagist) Vendor— Affected 4.0.0 to before 4.4.37 Fixed in 4.4.37 Patch available GHSA-vcgg-hp4r-87gx
  • contao/contao (Packagist) Vendor— Affected 4.5.0 to before 4.7.3 Fixed in 4.7.3 Patch available GHSA-vcgg-hp4r-87gx
  • contao/core-bundle (Packagist) Vendor— Affected 4.0.0 to before 4.4.37 Fixed in 4.4.37 Patch available GHSA-vcgg-hp4r-87gx
  • contao/core-bundle (Packagist) Vendor— Affected 4.5.0 to before 4.7.3 Fixed in 4.7.3 Patch available GHSA-vcgg-hp4r-87gx
  • contao/core (Packagist) Vendor— Affected 3.0.0 to before 3.5.39 Fixed in 3.5.39 Patch available GHSA-vcgg-hp4r-87gx

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:contao:contao_cms:*:*:*:*:*:*:*:*before 3.5.39; 4.0.0 to before 4.7.3Vulnerablecontao
  • cpe:2.3:a:contao:contao_cms:*:*:*:*:*:*:*:* Versions before 3.5.39; 4.0.0 to before 4.7.3 Vulnerable ·contao

Remediation

  • Fix · GHSA-vcgg-hp4r-87gx contao/contao (Packagist) Fixed in 4.4.37 Advisory →
  • Fix · GHSA-vcgg-hp4r-87gx contao/contao (Packagist) Fixed in 4.7.3 Advisory →
  • Fix · GHSA-vcgg-hp4r-87gx contao/core-bundle (Packagist) Fixed in 4.4.37 Advisory →
  • Fix · GHSA-vcgg-hp4r-87gx contao/core-bundle (Packagist) Fixed in 4.7.3 Advisory →
  • Fix · GHSA-vcgg-hp4r-87gx contao/core (Packagist) Fixed in 3.5.39 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2019-10641
  2. 2026-10-03 Alias added: GHSA-vcgg-hp4r-87gx

References

  • TI-2014-01453 Contao CMS through 3.2.4 has PHP Object Injection Vulnerabilities CVSS 3.1CRITICAL 9.8
  • TI-2019-07939 Contao 4.7 allows Use of a Key Past its Expiration Date. CVSS 3.0CRITICAL 9.8
  • TI-2017-12170 Contao 3.0.0 to 3.5.30 and 4.0.0 to 4.4.7 contains an SQL injection vulnerability in the… CVSS 3.0CRITICAL 9.8
  • TI-2017-08073 Contao before 3.5.28 and 4.x before 4.4.1 allows remote attackers to include and execute… CVSS 3.0HIGH 8.8
  • TI-2019-07938 Contao 4.7 allows CSRF. CVSS 3.0HIGH 8.8
  • TI-2012-01169 Multiple cross-site request forgery (CSRF) vulnerabilities in main.php in Contao… CVSS 2.0MEDIUM 6.8
See all 10 →

Sources