A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting…
Priority LOW 36CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting versions < 8.12. This vulnerability allows an attacker to acquire authenticated users' tokens and invoke services on a user's behalf if the target site or application uses a popup callback page with auth0.popup.callback().
Why it matters now
EPSS 0.0142 72nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed auth0-js (npm): 8.12.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | auth0-js (npm) | before 8.12.0 | 8.12.0 | Patch available | GHSA-3rpr-mg43-xhq4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- auth0-js (npm) Vendor— Affected before 8.12.0 Fixed in 8.12.0 Patch available GHSA-3rpr-mg43-xhq4
Remediation
- Fix · GHSA-3rpr-mg43-xhq4 auth0-js (npm) Fixed in 8.12.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-17068
- 2026-10-03 Alias added: GHSA-3rpr-mg43-xhq4
References
Advisory 3
More Auth0.js vulnerabilities
- TI-2018-05020 The Auth0 authentication service before 2017-10-15 allows privilege escalation because… CVSS 3.0CRITICAL 9.8
- TI-2018-05300 The Auth0 Auth0.js library before 9.3 has CSRF because it mishandles the case where the… CVSS 3.0HIGH 8.8
- TI-2018-05021 CSRF exists in the Auth0 authentication service through 14591 if the Legacy Lock API flag is enabled. CVSS 3.0HIGH 8.8
- TI-2020-11898 Authorization header is not sanitized in an error object in auth0 CVSS 3.1HIGH 7.7
- TI-2026-30591 Improper Permission Checking in Auth.js SDK CVSS 3.1HIGH 7.1
- TI-2020-04319 Information disclosure through error object CVSS 3.1MEDIUM 5.5
Sources
- CVE-2017-17068 · CVE Program
- CVE-2017-17068 · NVD
- FIRST EPSS
- GHSA-3rpr-mg43-xhq4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences