CSRF exists in the Auth0 authentication service through 14591 if the Legacy Lock API flag is enabled.
Priority LOW 39CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
CSRF exists in the Auth0 authentication service through 14591 if the Legacy Lock API flag is enabled.
Why it matters now
EPSS 0.00736 54th percentileScored 2026-11-07
Fix Fixed auth0-js (npm): 9.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | auth0-js (npm) | before 9.0.0 | 9.0.0 | Patch available | GHSA-wv26-rj8c-4r33 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- auth0-js (npm) Vendor— Affected before 9.0.0 Fixed in 9.0.0 Patch available GHSA-wv26-rj8c-4r33
Remediation
- Fix · GHSA-wv26-rj8c-4r33 auth0-js (npm) Fixed in 9.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6874
- 2026-10-03 Alias added: GHSA-wv26-rj8c-4r33
References
More Auth0.js vulnerabilities
- TI-2018-05020 The Auth0 authentication service before 2017-10-15 allows privilege escalation because… CVSS 3.0CRITICAL 9.8
- TI-2018-05300 The Auth0 Auth0.js library before 9.3 has CSRF because it mishandles the case where the… CVSS 3.0HIGH 8.8
- TI-2020-11898 Authorization header is not sanitized in an error object in auth0 CVSS 3.1HIGH 7.7
- TI-2017-12531 A cross-origin vulnerability has been discovered in the Auth0 auth0.js library affecting… CVSS 3.0HIGH 7.5
- TI-2026-30591 Improper Permission Checking in Auth.js SDK CVSS 3.1HIGH 7.1
- TI-2020-04319 Information disclosure through error object CVSS 3.1MEDIUM 5.5
Sources
- CVE-2018-6874 · CVE Program
- CVE-2018-6874 · NVD
- FIRST EPSS
- GHSA-wv26-rj8c-4r33 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences