An XSS issue was discovered in Designer Studio in Pegasystems Pega Platform 7.1.7, 7.1.8…
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
An XSS issue was discovered in Designer Studio in Pegasystems Pega Platform 7.1.7, 7.1.8, 7.1.9, 7.1.10, 7.2, 7.2.1, and 7.2.2. A user with developer credentials can insert malicious code (up to 64 characters) into a text field in Designer Studio, after establishing context. Designer Studio is the developer workbench for Pega Platform. That XSS payload will execute when other developers visit the affected pages.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pega:pega_platform:7.1.7:*:*:*:*:*:*:* | 7.1.7 | Vulnerable | Pegasystems |
| cpe:2.3:a:pega:pega_platform:7.1.8:*:*:*:*:*:*:* | 7.1.8 | Vulnerable | Pegasystems |
| cpe:2.3:a:pega:pega_platform:7.1.9:*:*:*:*:*:*:* | 7.1.9 | Vulnerable | Pegasystems |
| cpe:2.3:a:pega:pega_platform:7.1.10:*:*:*:*:*:*:* | 7.1.10 | Vulnerable | Pegasystems |
| cpe:2.3:a:pega:pega_platform:7.2:*:*:*:*:*:*:* | 7.2 | Vulnerable | Pegasystems |
| cpe:2.3:a:pega:pega_platform:7.2.1:*:*:*:*:*:*:* | 7.2.1 | Vulnerable | Pegasystems |
| cpe:2.3:a:pega:pega_platform:7.2.2:*:*:*:*:*:*:* | 7.2.2 | Vulnerable | Pegasystems |
- cpe:2.3:a:pega:pega_platform:7.1.7:*:*:*:*:*:*:* Versions 7.1.7 Vulnerable ·Pegasystems
- cpe:2.3:a:pega:pega_platform:7.1.8:*:*:*:*:*:*:* Versions 7.1.8 Vulnerable ·Pegasystems
- cpe:2.3:a:pega:pega_platform:7.1.9:*:*:*:*:*:*:* Versions 7.1.9 Vulnerable ·Pegasystems
- cpe:2.3:a:pega:pega_platform:7.1.10:*:*:*:*:*:*:* Versions 7.1.10 Vulnerable ·Pegasystems
- cpe:2.3:a:pega:pega_platform:7.2:*:*:*:*:*:*:* Versions 7.2 Vulnerable ·Pegasystems
- cpe:2.3:a:pega:pega_platform:7.2.1:*:*:*:*:*:*:* Versions 7.2.1 Vulnerable ·Pegasystems
- cpe:2.3:a:pega:pega_platform:7.2.2:*:*:*:*:*:*:* Versions 7.2.2 Vulnerable ·Pegasystems
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2017-17478
- 2026-10-03 Alias added: GHSA-pxm5-gqw8-pwg8
References
More Pegasystems Pega Platform vulnerabilities
- TI-2023-15393 Pega platform clients who are using versions 6.1 through 7.3.1 may be utilizing default credentials CVSS 3.1CRITICAL 9.8
- TI-2020-12137 pyActivity in Pega Platform 8.4.0.237 has a security misconfiguration that leads to an… CVSS 3.1CRITICAL 9.8
- TI-2023-12673 Pega platform clients who are using versions 7.4 through 8.8.x and have upgraded from a… CVSS 3.1CRITICAL 9.8
- TI-2020-07035 Pega Platform before version 8.2.6 is affected by a Reflected Cross-Site Scripting… CVSS 3.1HIGH 8.8
- TI-2019-12322 PEGA Platform 8.3.0 is vulnerable to a direct… CVSS 3.1HIGH 8.1
- TI-2025-01892 Pega Platform versions 8.4.3 to Infinity 24.2.1 are affected by an XSS issue with Mashup CVSS 3.1HIGH 8.1
Sources
- CVE-2017-17478 · CVE Program
- CVE-2017-17478 · NVD
- FIRST EPSS
- GHSA-pxm5-gqw8-pwg8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences