Read the docs

Pegasystems

Records60All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical9CVSS 9.0–10.0
CVSS high14CVSS 7.0–8.9

Exploited now

Pegasystems records in CISA KEV

No Pegasystems vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

29 records in Pega Platform · all components

Priority LOW 37

PEGA Platform 8.3.0 is vulnerable to a direct prweb/sso/random_token/!STANDARD?pyActivity=Data-Admin-DB-Name.DBSchema_ListDatabases request while using a low-privilege account.

CVSS 3.1HIGH 8.1 Network Low privileges No interaction EPSS 0.01045 Published 2019-11-26 No fix listed CWE-668
Priority LOW 35

The application distribution export functionality in PEGA Platform 7.2 ML0 and earlier allows remote authenticated users with certain privileges to obtain sensitive configuration information by leveraging a missing acces…

CVSS 3.0MEDIUM 6.5 Network Low privileges No interaction EPSS 0.03503 Published 2017-08-02 No fix listed CWE-200
Priority LOW 33

Multiple cross-site scripting (XSS) vulnerabilities in PEGA Platform 7.2 ML0 and earlier allow remote attackers to inject arbitrary web script or HTML via the (1) PATH_INFO to the main page; the (2) beanReference paramet…

CVSS 3.0MEDIUM 6.1 Network No auth User interaction EPSS 0.02904 Published 2017-08-02 No fix listed CWE-79
Priority LOW 29

Pega Platform versions 8.7.5 to Infinity 24.2.2 are affected by a Insecure Direct Object Reference issue in a user interface component that can only be used to read data.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00409 Published 2025-10-16 Fixed in Infinity 24.2.3 CWE-639
Priority LOW 28

Pega Platform through 8.4.x is affected by Cross Site Scripting (XSS) via the ConnectionID parameter, as demonstrated by a pyActivity=Data-TRACERSettings.pzStartTracerSession request to a PRAuth URI.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00686 Published 2020-12-15 No fix listed CWE-79
Priority LOW 24

Pega Platform versions 7.1.0 to Infinity 24.2.2 are affected by a Stored XSS issue in a user interface component.

CVSS 3.1MEDIUM 5.5 Network High privileges No interaction EPSS 0.00195 Published 2025-09-10 Fixed in Infinity 24.2.3 CWE-79
Priority LOW 22

Pega Platform versions 8.1.0 through 25.1.1 are affected by an HTML Injection vulnerability in a user interface component.

CVSS 4.0MEDIUM 5.1 Network High privileges No interaction EPSS 0.00187 Published 2026-04-15 Fixed in Infinity 25.1.2 CWE-80
Priority LOW 22

Pega Platform versions 8.1.0 through 25.1.2 are affected by an Reflected Cross-site scripting (XSS) vulnerability in a user interface component.

CVSS 4.0MEDIUM 4.8 Network High privileges User interaction EPSS 0.00242 Published 2026-07-15 Fixed in Infinity 25.1.2 CWE-79
Priority LOW 22

Pega Platform versions 8.1.0 through 25.1.0 are affected by a Stored Cross-site Scripting vulnerability in a user interface component.

CVSS 4.0MEDIUM 4.8 Network High privileges User interaction EPSS 0.00268 Published 2026-03-31 Fixed in Infinity 25.1.0 CWE-79
TI-2023-04459 CVE-2023-4843 · GHSA-jmp8-vc2x-6f9g

Injection in Pegasystems Pega Platform

Priority LOW 22

Pega Platform versions 7.1 to 8.8.3 are affected by an HTML Injection issue with a name field utilized in Visual Business Director, however this field can only be modified by an authenticated administrative user.

CVSS 3.1MEDIUM 4.8 Network High privileges User interaction EPSS 0.00341 Published 2023-09-08 Fixed in 8.8.4 CWE-74
Priority LOW 21

Pega Platform versions 8.1.0 through 25.1.1 are affected by a Stored Cross-Site Scripting vulnerability in a user interface component.

CVSS 4.0MEDIUM 4.8 Network High privileges User interaction EPSS 0.00187 Published 2026-04-15 Fixed in Infinity 25.1.2 CWE-79
Load more
Open these records in search →