A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <=…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.
Summary
A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | io.swagger:swagger-parser (Maven) | before 1.0.31 | 1.0.31 | Patch available | GHSA-vgvf-9jh3-fg75 |
| — | io.swagger:swagger-codegen (Maven) | before 2.2.2 | 2.2.2 | Patch available | GHSA-vgvf-9jh3-fg75 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- io.swagger:swagger-parser (Maven) Vendor— Affected before 1.0.31 Fixed in 1.0.31 Patch available GHSA-vgvf-9jh3-fg75
- io.swagger:swagger-codegen (Maven) Vendor— Affected before 2.2.2 Fixed in 2.2.2 Patch available GHSA-vgvf-9jh3-fg75
Remediation
- Fix · GHSA-vgvf-9jh3-fg75 io.swagger:swagger-parser (Maven) Fixed in 1.0.31 Advisory →
- Fix · GHSA-vgvf-9jh3-fg75 io.swagger:swagger-codegen (Maven) Fixed in 2.2.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000207
- 2026-10-03 Alias added: GHSA-vgvf-9jh3-fg75
References
More Swagger-codegen vulnerabilities
- TI-2017-14526 A vulnerability in Swagger-Parser's (version <= 1.0.30) yaml parsing functionality… CVSS 3.0HIGH 8.8
Sources
- CVE-2017-1000207 · CVE Program
- CVE-2017-1000207 · NVD
- FIRST EPSS
- GHSA-vgvf-9jh3-fg75 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences