Read the docs

Swagger

Records2All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical0CVSS 9.0–10.0
CVSS high2CVSS 7.0–8.9

Exploited now

Swagger records in CISA KEV

No Swagger vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

2 records

Priority MEDIUM 41

A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <= 2.2.2 yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is par…

CVSS 3.0HIGH 8.8 Network No auth User interaction EPSS 0.01623 Published 2017-11-27 Fixed in 1.0.31, 2.2.2 CWE-502
Open these records in search →