Read the docs

A vulnerability in Swagger-Parser's (version <= 1.0.30) yaml parsing functionality…

Priority MEDIUM 41CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

A vulnerability in Swagger-Parser's (version <= 1.0.30) yaml parsing functionality results in arbitrary code being executed when a maliciously crafted yaml Open-API specification is parsed. This in particular, affects the 'generate' and 'validate' command in swagger-codegen (<= 2.2.2) and can lead to arbitrary code being executed when these commands are used on a well-crafted yaml specification.

Why it matters now

EPSS 0.01705 77th percentileScored 2026-11-07
Fix Fixed io.swagger:swagger-codegen (Maven): 2.2.2io.swagger:swagger-parser (Maven): 1.0.31

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—io.swagger:swagger-codegen (Maven)before 2.2.22.2.2Patch availableGHSA-q7pf-qr96-2vq5
—io.swagger:swagger-parser (Maven)before 1.0.311.0.31Patch availableGHSA-q7pf-qr96-2vq5
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • io.swagger:swagger-codegen (Maven) Vendor— Affected before 2.2.2 Fixed in 2.2.2 Patch available GHSA-q7pf-qr96-2vq5
  • io.swagger:swagger-parser (Maven) Vendor— Affected before 1.0.31 Fixed in 1.0.31 Patch available GHSA-q7pf-qr96-2vq5

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:swagger:swagger-codegen:*:*:*:*:*:*:*:*up to 2.2.2VulnerableSwagger
cpe:2.3:a:swagger:swagger-parser:*:*:*:*:*:*:*:*up to 1.0.30VulnerableSwagger
  • cpe:2.3:a:swagger:swagger-codegen:*:*:*:*:*:*:*:* Versions up to 2.2.2 Vulnerable ·Swagger
  • cpe:2.3:a:swagger:swagger-parser:*:*:*:*:*:*:*:* Versions up to 1.0.30 Vulnerable ·Swagger

Remediation

  • Fix · GHSA-q7pf-qr96-2vq5 io.swagger:swagger-codegen (Maven) Fixed in 2.2.2 Advisory →
  • Fix · GHSA-q7pf-qr96-2vq5 io.swagger:swagger-parser (Maven) Fixed in 1.0.31 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2017-1000208
  2. 2026-10-03 Alias added: GHSA-q7pf-qr96-2vq5

References

  • TI-2017-14525 A vulnerability in Swagger-Parser's version <= 1.0.30 and Swagger codegen version <=… CVSS 3.0HIGH 8.8

Sources