Python package pysaml2 version 4.4.0 and earlier reuses the initialization vector across…
Priority LOW 26CWE-330Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 6 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Python package pysaml2 version 4.4.0 and earlier reuses the initialization vector across encryptions in the IDP server, resulting in weak encryption of data.
Why it matters now
EPSS 0.00888 59th percentileScored 2026-11-07
Fix Partial pysaml2 (PyPI): 4.6.0Red Hat: 6 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pysaml2 (PyPI) | before 4.6.0 | 4.6.0 | Patch available | GHSA-cq94-qf6q-mf2h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pysaml2 (PyPI) Vendor— Affected before 4.6.0 Fixed in 4.6.0 Patch available GHSA-cq94-qf6q-mf2h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pysaml2_project:pysaml2:*:*:*:*:*:*:*:* | before 4.6.0 | Vulnerable | Pysaml2 Project |
- cpe:2.3:a:pysaml2_project:pysaml2:*:*:*:*:*:*:*:* Versions before 4.6.0 Vulnerable ·Pysaml2 Project
Remediation
- Fix · GHSA-cq94-qf6q-mf2h pysaml2 (PyPI) Fixed in 4.6.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux OpenStack Platform 7 (Kilo) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 10 (Newton) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 11 (Ocata) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 12 (Pike) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 8 (Liberty) | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 9 (Mitaka) | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000246
- 2026-10-03 Alias added: GHSA-cq94-qf6q-mf2h
References
More Pysaml2 Project Pysaml2 vulnerabilities
- TI-2016-08203 PySAML2 allows remote attackers to conduct XML external entity (XXE) attacks via a crafted SAML XML request or response. CVSS 3.0CRITICAL 9.0
- TI-2016-08225 XML External Entity (XXE) vulnerability in PySAML2 4.4.0 and earlier allows remote… CVSS 3.0HIGH 7.5
- TI-2017-14652 pysaml2 version 4.4.0 and older accept any password when run with python optimizations… CVSS 3.1HIGH 8.1
- TI-2020-04437 PySAML2 before 5.0.0 does not check that the signature in a SAML document is enveloped… CVSS 3.1HIGH 7.5
- TI-2021-04342 Open default xmlsec1 key-type preference CVSS 3.1MEDIUM 6.5
- TI-2021-04341 SAML XML Signature wrapping CVSS 3.1MEDIUM 6.5
Sources
- CVE-2017-1000246 · CVE Program
- CVE-2017-1000246 · NVD
- FIRST EPSS
- GHSA-cq94-qf6q-mf2h · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000246 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences