phpBB version 3.2.0 is vulnerable to SSRF in the Remote Avatar function resulting…
Priority LOW 36CWE-918Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.
Summary
phpBB version 3.2.0 is vulnerable to SSRF in the Remote Avatar function resulting allowing an attacker to perform port scanning, requesting internal content and potentially attacking such internal services via the web application.
Why it matters now
EPSS 0.01318 70th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpbb/phpbb (Packagist): 3.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | phpbb/phpbb (Packagist) | 3.2.0 to before 3.2.1 | 3.2.1 | Patch available | GHSA-9jm4-rg99-566c |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- phpbb/phpbb (Packagist) Vendor— Affected 3.2.0 to before 3.2.1 Fixed in 3.2.1 Patch available GHSA-9jm4-rg99-566c
Remediation
- Fix · GHSA-9jm4-rg99-566c phpbb/phpbb (Packagist) Fixed in 3.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000419
- 2026-10-03 Alias added: GHSA-9jm4-rg99-566c
References
More Phpbb vulnerabilities
- TI-2025-43137 Cross Site Request Forgery vulnerability in Phpbb phbb3 v.3.3.15 allows a local attacker… CVSS 3.1HIGH 8.8
- TI-2001-01423 prefs.php in phpBB 1.4.0 and earlier allows remote authenticated users to execute… CVSS 3.1HIGH 8.8
- TI-2008-03086 Unspecified vulnerability in phpBB before 3.0.1 has unknown impact and attack vectors… CVSS 2.0HIGH 10.0
- TI-2008-01694 Multiple unspecified vulnerabilities in phpBB before 3.0.1 have unknown impact and attack… CVSS 2.0HIGH 10.0
- TI-2006-06909 PHP remote file inclusion vulnerability in includes/not_mem.php in the Add Name module… CVSS 2.0HIGH 7.5
- TI-2019-12678 In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a… CVSS 3.1HIGH 8.8
Sources
- CVE-2017-1000419 · CVE Program
- CVE-2017-1000419 · NVD
- FIRST EPSS
- GHSA-9jm4-rg99-566c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences