Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the…
Priority MEDIUM 51CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the "add repo" component resulting in arbitrary code execution as root user.
Why it matters now
EPSS 0.05556 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial cobbler (PyPI): 3.0.0Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cobbler (PyPI) | before 3.0.0 | 3.0.0 | Patch available | GHSA-96hw-v598-jvgh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cobbler (PyPI) Vendor— Affected before 3.0.0 Fixed in 3.0.0 Patch available GHSA-96hw-v598-jvgh
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* | up to 2.8.2 | Vulnerable | The Cobbler Project |
- cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* Versions up to 2.8.2 Vulnerable ·The Cobbler Project
Remediation
- Fix · GHSA-96hw-v598-jvgh cobbler (PyPI) Fixed in 3.0.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 5 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2017-1000469
- 2026-10-03 Alias added: GHSA-96hw-v598-jvgh
References
More The Cobbler Project Cobbler vulnerabilities
- TI-2021-17397 Cobbler before 3.3.0 allows log poisoning, and resultant Remote Code Execution, via an… CVSS 3.1CRITICAL 9.8
- TI-2018-07743 It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface… CVSS 3.0CRITICAL 9.8
- TI-2021-17398 Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data. CVSS 3.1HIGH 7.5
- TI-2022-00766 Improper Authorization in cobbler/cobbler CVSS 3.1CRITICAL 9.1
- TI-2021-17399 Cobbler before 3.3.0 allows authorization bypass for modification of settings. CVSS 3.1HIGH 7.5
- TI-2021-20416 An issue was discovered in Cobbler before 3.3.1. CVSS 3.1HIGH 7.8
Sources
- CVE-2017-1000469 · CVE Program
- CVE-2017-1000469 · NVD
- FIRST EPSS
- GHSA-96hw-v598-jvgh · GitHub Advisory Database · CC BY 4.0
- CVE-2017-1000469 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences