Read the docs
TI-2021-17397 Aliases CVE-2021-40323GHSA-cpqf-3c3r-c9g2

Cobbler before 3.3.0 allows log poisoning, and resultant Remote Code Execution, via an…

Priority HIGH 84CWE-94Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

Cobbler before 3.3.0 allows log poisoning, and resultant Remote Code Execution, via an XMLRPC method that logs to the logfile for template injection.

Why it matters now

EPSS 0.86829 99th percentileScored 2026-11-07
Fix Fixed cobbler (PyPI): 3.3.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—cobbler (PyPI)before 3.3.03.3.0Patch availableGHSA-cpqf-3c3r-c9g2
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • cobbler (PyPI) Vendor— Affected before 3.3.0 Fixed in 3.3.0 Patch available GHSA-cpqf-3c3r-c9g2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:*up to 3.3.0VulnerableThe Cobbler Project
  • cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* Versions up to 3.3.0 Vulnerable ·The Cobbler Project

Remediation

  • Fix · GHSA-cpqf-3c3r-c9g2 cobbler (PyPI) Fixed in 3.3.0 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat Enterprise Linux 8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-40323
  2. 2026-10-03 Alias added: GHSA-cpqf-3c3r-c9g2

References

  • TI-2018-07743 It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface… CVSS 3.0CRITICAL 9.8
  • TI-2021-17398 Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data. CVSS 3.1HIGH 7.5
  • TI-2017-14678 Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the… CVSS 3.0CRITICAL 9.8
  • TI-2022-00766 Improper Authorization in cobbler/cobbler CVSS 3.1CRITICAL 9.1
  • TI-2021-17399 Cobbler before 3.3.0 allows authorization bypass for modification of settings. CVSS 3.1HIGH 7.5
  • TI-2021-20416 An issue was discovered in Cobbler before 3.3.1. CVSS 3.1HIGH 7.8
See all 10 →

Sources