Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.
Priority HIGH 70CWE-434Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-434.
Summary
Cobbler before 3.3.0 allows arbitrary file write operations via upload_log_data.
Why it matters now
EPSS 0.68635 99th percentileScored 2026-11-07
Fix Fixed cobbler (PyPI): 3.3.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cobbler (PyPI) | before 3.3.0 | 3.3.0 | Patch available | GHSA-4cfr-gjfx-fj3x |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cobbler (PyPI) Vendor— Affected before 3.3.0 Fixed in 3.3.0 Patch available GHSA-4cfr-gjfx-fj3x
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* | up to 3.3.0 | Vulnerable | The Cobbler Project |
- cpe:2.3:a:cobbler_project:cobbler:*:*:*:*:*:*:*:* Versions up to 3.3.0 Vulnerable ·The Cobbler Project
Remediation
- Fix · GHSA-4cfr-gjfx-fj3x cobbler (PyPI) Fixed in 3.3.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Linux 8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-40324
- 2026-10-03 Alias added: GHSA-4cfr-gjfx-fj3x
References
Advisory 3
More The Cobbler Project Cobbler vulnerabilities
- TI-2021-17397 Cobbler before 3.3.0 allows log poisoning, and resultant Remote Code Execution, via an… CVSS 3.1CRITICAL 9.8
- TI-2018-07743 It was found that cobbler 2.6.x exposed all functions from its CobblerXMLRPCInterface… CVSS 3.0CRITICAL 9.8
- TI-2017-14678 Cobbler version up to 2.8.2 is vulnerable to a command injection vulnerability in the… CVSS 3.0CRITICAL 9.8
- TI-2022-00766 Improper Authorization in cobbler/cobbler CVSS 3.1CRITICAL 9.1
- TI-2021-17399 Cobbler before 3.3.0 allows authorization bypass for modification of settings. CVSS 3.1HIGH 7.5
- TI-2021-20416 An issue was discovered in Cobbler before 3.3.1. CVSS 3.1HIGH 7.8
Sources
- CVE-2021-40324 · CVE Program
- CVE-2021-40324 · NVD
- FIRST EPSS
- GHSA-4cfr-gjfx-fj3x · GitHub Advisory Database · CC BY 4.0
- CVE-2021-40324 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences