Read the docs
TI-2018-00963 Aliases CVE-2018-1042GHSA-qqjv-mc2v-p7mc

Moodle 3.x has Server Side Request Forgery in the filepicker.

Priority MEDIUM 45CWE-918Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.

Summary

Moodle 3.x has Server Side Request Forgery in the filepicker.

Why it matters now

EPSS 0.16245 96th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.4.1, 3.3.4, 3.2.7 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Moodle 3.xMoodle 3.x—No fix listedCNA
—moodle/moodle (Packagist)3.4 to before 3.4.13.4.1Patch availableGHSA-qqjv-mc2v-p7mc
—moodle/moodle (Packagist)3.3 to before 3.3.43.3.4Patch availableGHSA-qqjv-mc2v-p7mc
—moodle/moodle (Packagist)3.2 to before 3.2.73.2.7Patch availableGHSA-qqjv-mc2v-p7mc
—moodle/moodle (Packagist)3.1 to before 3.1.103.1.10Patch availableGHSA-qqjv-mc2v-p7mc
  • Moodle 3.x Vendor— Affected Moodle 3.x Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.4 to before 3.4.1 Fixed in 3.4.1 Patch available GHSA-qqjv-mc2v-p7mc
  • moodle/moodle (Packagist) Vendor— Affected 3.3 to before 3.3.4 Fixed in 3.3.4 Patch available GHSA-qqjv-mc2v-p7mc
  • moodle/moodle (Packagist) Vendor— Affected 3.2 to before 3.2.7 Fixed in 3.2.7 Patch available GHSA-qqjv-mc2v-p7mc
  • moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.10 Fixed in 3.1.10 Patch available GHSA-qqjv-mc2v-p7mc

CPE configurations NVD · 13

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*up to 3.1.9VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:*3.2.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:*3.2.1VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.2:*:*:*:*:*:*:*3.2.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.3:*:*:*:*:*:*:*3.2.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.4:*:*:*:*:*:*:*3.2.4VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.5:*:*:*:*:*:*:*3.2.5VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.2.6:*:*:*:*:*:*:*3.2.6VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.3.0:*:*:*:*:*:*:*3.3.0VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.3.1:*:*:*:*:*:*:*3.3.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 3.1.9 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.2:*:*:*:*:*:*:* Versions 3.2.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.3:*:*:*:*:*:*:* Versions 3.2.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.4:*:*:*:*:*:*:* Versions 3.2.4 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.5:*:*:*:*:*:*:* Versions 3.2.5 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.2.6:*:*:*:*:*:*:* Versions 3.2.6 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.3.0:*:*:*:*:*:*:* Versions 3.3.0 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Moodle
Show 3 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:3.3.2:*:*:*:*:*:*:*3.3.2VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.3.3:*:*:*:*:*:*:*3.3.3VulnerableMoodle
cpe:2.3:a:moodle:moodle:3.4.0:*:*:*:*:*:*:*3.4.0VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:3.3.2:*:*:*:*:*:*:* Versions 3.3.2 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.3.3:*:*:*:*:*:*:* Versions 3.3.3 Vulnerable ·Moodle
  • cpe:2.3:a:moodle:moodle:3.4.0:*:*:*:*:*:*:* Versions 3.4.0 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-qqjv-mc2v-p7mc moodle/moodle (Packagist) Fixed in 3.4.1 Advisory →
  • Fix · GHSA-qqjv-mc2v-p7mc moodle/moodle (Packagist) Fixed in 3.3.4 Advisory →
  • Fix · GHSA-qqjv-mc2v-p7mc moodle/moodle (Packagist) Fixed in 3.2.7 Advisory →
  • Fix · GHSA-qqjv-mc2v-p7mc moodle/moodle (Packagist) Fixed in 3.1.10 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1042
  2. 2026-10-03 Alias added: GHSA-qqjv-mc2v-p7mc

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources