In Moodle 3.x, there is XSS via a calendar event name.
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
In Moodle 3.x, there is XSS via a calendar event name.
Why it matters now
EPSS 0.00967 61st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.3.4, 3.2.7, 3.1.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Moodle 3.x | Moodle 3.x | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.3 to before 3.3.4 | 3.3.4 | Patch available | GHSA-595j-wpfg-23w4 |
| — | moodle/moodle (Packagist) | 3.2 to before 3.2.7 | 3.2.7 | Patch available | GHSA-595j-wpfg-23w4 |
| — | moodle/moodle (Packagist) | 3.1 to before 3.1.10 | 3.1.10 | Patch available | GHSA-595j-wpfg-23w4 |
- Moodle 3.x Vendor— Affected Moodle 3.x Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.3 to before 3.3.4 Fixed in 3.3.4 Patch available GHSA-595j-wpfg-23w4
- moodle/moodle (Packagist) Vendor— Affected 3.2 to before 3.2.7 Fixed in 3.2.7 Patch available GHSA-595j-wpfg-23w4
- moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.10 Fixed in 3.1.10 Patch available GHSA-595j-wpfg-23w4
CPE configurations NVD · 12
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 3.1.9 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.2:*:*:*:*:*:*:* | 3.2.2 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.3:*:*:*:*:*:*:* | 3.2.3 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.4:*:*:*:*:*:*:* | 3.2.4 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.5:*:*:*:*:*:*:* | 3.2.5 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.2.6:*:*:*:*:*:*:* | 3.2.6 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.3.0:*:*:*:*:*:*:* | 3.3.0 | Vulnerable | Moodle |
| cpe:2.3:a:moodle:moodle:3.3.1:*:*:*:*:*:*:* | 3.3.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 3.1.9 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.2:*:*:*:*:*:*:* Versions 3.2.2 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.3:*:*:*:*:*:*:* Versions 3.2.3 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.4:*:*:*:*:*:*:* Versions 3.2.4 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.5:*:*:*:*:*:*:* Versions 3.2.5 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.2.6:*:*:*:*:*:*:* Versions 3.2.6 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.3.0:*:*:*:*:*:*:* Versions 3.3.0 Vulnerable ·Moodle
- cpe:2.3:a:moodle:moodle:3.3.1:*:*:*:*:*:*:* Versions 3.3.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-595j-wpfg-23w4 moodle/moodle (Packagist) Fixed in 3.3.4 Advisory →
- Fix · GHSA-595j-wpfg-23w4 moodle/moodle (Packagist) Fixed in 3.2.7 Advisory →
- Fix · GHSA-595j-wpfg-23w4 moodle/moodle (Packagist) Fixed in 3.1.10 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1045
- 2026-10-03 Alias added: GHSA-595j-wpfg-23w4
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2018-1045 · CVE Program
- CVE-2018-1045 · NVD
- FIRST EPSS
- GHSA-595j-wpfg-23w4 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1045 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences