Read the docs
TI-2018-01054 Aliases CVE-2018-1137GHSA-vxqh-mx28-7ghw

Improper input validation in Moodle 3.x unknown

Priority LOW 39CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.

Summary

An issue was discovered in Moodle 3.x. By substituting URLs in portfolios, users can instantiate any class. This can also be exploited by users who are logged in as guests to create a DDoS attack.

Why it matters now

EPSS 0.01708 77th percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.1.12, 3.2.9, 3.3.6 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—Moodle 3.x unknownMoodle 3.x unknown—No fix listedCNA
—moodle/moodle (Packagist)3.1 to before 3.1.123.1.12Patch availableGHSA-vxqh-mx28-7ghw
—moodle/moodle (Packagist)3.2 to before 3.2.93.2.9Patch availableGHSA-vxqh-mx28-7ghw
—moodle/moodle (Packagist)3.3 to before 3.3.63.3.6Patch availableGHSA-vxqh-mx28-7ghw
—moodle/moodle (Packagist)3.4 to before 3.4.33.4.3Patch availableGHSA-vxqh-mx28-7ghw
  • Moodle 3.x unknown Vendor— Affected Moodle 3.x unknown Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.12 Fixed in 3.1.12 Patch available GHSA-vxqh-mx28-7ghw
  • moodle/moodle (Packagist) Vendor— Affected 3.2 to before 3.2.9 Fixed in 3.2.9 Patch available GHSA-vxqh-mx28-7ghw
  • moodle/moodle (Packagist) Vendor— Affected 3.3 to before 3.3.6 Fixed in 3.3.6 Patch available GHSA-vxqh-mx28-7ghw
  • moodle/moodle (Packagist) Vendor— Affected 3.4 to before 3.4.3 Fixed in 3.4.3 Patch available GHSA-vxqh-mx28-7ghw

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.1.0 – 3.1.11; 3.2.0 – 3.2.8; 3.3.0 – 3.3.5; 3.4.0 – 3.4.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.1.0 – 3.1.11; 3.2.0 – 3.2.8; 3.3.0 – 3.3.5; 3.4.0 – 3.4.2 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-vxqh-mx28-7ghw moodle/moodle (Packagist) Fixed in 3.1.12 Advisory →
  • Fix · GHSA-vxqh-mx28-7ghw moodle/moodle (Packagist) Fixed in 3.2.9 Advisory →
  • Fix · GHSA-vxqh-mx28-7ghw moodle/moodle (Packagist) Fixed in 3.3.6 Advisory →
  • Fix · GHSA-vxqh-mx28-7ghw moodle/moodle (Packagist) Fixed in 3.4.3 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1137
  2. 2026-10-03 Alias added: GHSA-vxqh-mx28-7ghw

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources