Link following in Dell EMC Spring Boot
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub.
Summary
Spring Boot supports an embedded launch script that can be used to easily run the application as a systemd or init.d linux service. The script included with Spring Boot 1.5.9 and earlier and 2.0.0.M1 through 2.0.0.M7 is susceptible to a symlink attack which allows the "run_user" to overwrite and take ownership of any file on the same system. In order to instigate the attack, the application must be installed as a service and the "run_user" requires shell access to the server. Spring Boot application that are not installed as a service, or are not using the embedded launch script are not susceptible.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell EMC | Spring Boot | 1.5.0 - 1.5.9; 2.0.0.M1 - 2.0.0.M7 | — | No fix listed | CNA |
| — | org.springframework.boot:spring-boot (Maven) | 1.5.0 to before 1.5.10 | 1.5.10 | Patch available | GHSA-xx65-cc7g-9pfp |
- Spring Boot VendorDell EMC Affected 1.5.0 - 1.5.9; 2.0.0.M1 - 2.0.0.M7 Fixed in — No fix listed CNA
- org.springframework.boot:spring-boot (Maven) Vendor— Affected 1.5.0 to before 1.5.10 Fixed in 1.5.10 Patch available GHSA-xx65-cc7g-9pfp
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vmware:spring_boot:*:*:*:*:*:*:*:* | up to 1.5.9 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_boot:2.0.0:milestone1:*:*:*:*:*:* | 2.0.0 milestone1 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_boot:2.0.0:milestone2:*:*:*:*:*:* | 2.0.0 milestone2 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_boot:2.0.0:milestone3:*:*:*:*:*:* | 2.0.0 milestone3 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_boot:2.0.0:milestone4:*:*:*:*:*:* | 2.0.0 milestone4 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_boot:2.0.0:milestone5:*:*:*:*:*:* | 2.0.0 milestone5 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_boot:2.0.0:milestone6:*:*:*:*:*:* | 2.0.0 milestone6 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_boot:2.0.0:milestone7:*:*:*:*:*:* | 2.0.0 milestone7 | Vulnerable | VMware |
- cpe:2.3:a:vmware:spring_boot:*:*:*:*:*:*:*:* Versions up to 1.5.9 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_boot:2.0.0:milestone1:*:*:*:*:*:* Versions 2.0.0 milestone1 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_boot:2.0.0:milestone2:*:*:*:*:*:* Versions 2.0.0 milestone2 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_boot:2.0.0:milestone3:*:*:*:*:*:* Versions 2.0.0 milestone3 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_boot:2.0.0:milestone4:*:*:*:*:*:* Versions 2.0.0 milestone4 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_boot:2.0.0:milestone5:*:*:*:*:*:* Versions 2.0.0 milestone5 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_boot:2.0.0:milestone6:*:*:*:*:*:* Versions 2.0.0 milestone6 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_boot:2.0.0:milestone7:*:*:*:*:*:* Versions 2.0.0 milestone7 Vulnerable ·VMware
Remediation
- Fix · GHSA-xx65-cc7g-9pfp org.springframework.boot:spring-boot (Maven) Fixed in 1.5.10 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat JBoss Fuse 6
- Red Hat OpenShift Application Runtimes
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1196
- 2026-10-03 Alias added: GHSA-xx65-cc7g-9pfp
References
More Dell EMC vulnerabilities
- TI-2018-01128 Missing authorization in Dell EMC Avamar, Integrated Data Protection Appliance CVSS 3.0CRITICAL 9.8
- TI-2018-01141 OS command injection in Dell EMC RecoverPoint CVSS 3.0CRITICAL 9.8
- TI-2018-07852 Dell EMC Avamar and Integrated Data Protection Appliance Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2018-11243 Dell EMC ESRS Policy Manager versions 6.8 and prior contain a remote code execution… CVSS 3.0CRITICAL 9.8
- TI-2017-08041 OS command injection in Dell EMC Data Protection Advisor CVSS 3.1HIGH 8.8
Sources
- CVE-2018-1196 · CVE Program
- CVE-2018-1196 · NVD
- FIRST EPSS
- GHSA-xx65-cc7g-9pfp · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1196 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences