OS command injection in Dell EMC RecoverPoint
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
Dell EMC RecoverPoint versions prior to 5.1.2 and RecoverPoint for VMs versions prior to 5.1.1.3, contain a command injection vulnerability. An unauthenticated remote attacker may potentially exploit this vulnerability to execute arbitrary commands on the affected system with root privilege.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell EMC | Dell EMC RecoverPoint | before 5.1.2 | 5.1.2 | Patch available | CNA |
| Dell EMC | Dell EMC RecoverPoint Virtual Machine (VM) | before 5.1.1.3 | 5.1.1.3 | Patch available | CNA |
Remediation
- Fix · CNA Dell EMC RecoverPoint (Dell EMC) Fixed in 5.1.2
- Fix · CNA Dell EMC RecoverPoint Virtual Machine (VM) (Dell EMC) Fixed in 5.1.1.3
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell EMC RecoverPoint, Dell EMC RecoverPoint Virtual Machine (VM) 5.1.1.3, 5.1.2
3 records Highest priority Priority HIGH 1 HIGH, 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2018-01146 Sensitive information in log files in Dell EMC RecoverPointPriority MEDIUM 41
- TI-2018-01147 OS command injection in Dell EMC RecoverPointPriority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1235
- 2026-10-03 Alias added: GHSA-4mm7-92pv-gvpp
References
Exploit 1
More Dell EMC vulnerabilities
- TI-2018-01128 Missing authorization in Dell EMC Avamar, Integrated Data Protection Appliance CVSS 3.0CRITICAL 9.8
- TI-2018-07852 Dell EMC Avamar and Integrated Data Protection Appliance Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2018-11243 Dell EMC ESRS Policy Manager versions 6.8 and prior contain a remote code execution… CVSS 3.0CRITICAL 9.8
- TI-2017-08041 OS command injection in Dell EMC Data Protection Advisor CVSS 3.1HIGH 8.8
- TI-2019-02726 Buffer overflow in Dell EMC iDRAC CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-1235 · CVE Program
- CVE-2018-1235 · NVD
- FIRST EPSS
- GHSA-4mm7-92pv-gvpp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences