Memory corruption in Dell EMC NetWorker
Priority MEDIUM 49CWE-119Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-119 and the CVSS impact.
Summary
In Dell EMC NetWorker versions prior to 9.2.1.1, versions prior to 9.1.1.6, 9.0.x, and versions prior to 8.2.4.11, the 'nsrd' daemon causes a buffer overflow condition when handling certain messages. A remote unauthenticated attacker could potentially exploit this vulnerability to cause a denial of service to the users of NetWorker systems.
Why it matters now
EPSS 0.15722 96th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Dell EMC NetWorker (Dell EMC): 9.2.1.1, 9.1.1.6, 8.2.4.11
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell EMC | Dell EMC NetWorker | before 9.2.1.1; before 9.1.1.6; 9.0.x; before 8.2.4.11 | 9.2.1.1, 9.1.1.6, 8.2.4.11 | Patch available | CNA |
- Dell EMC NetWorker VendorDell EMC Affected before 9.2.1.1; before 9.1.1.6; 9.0.x; before 8.2.4.11 Fixed in 9.2.1.1, 9.1.1.6, 8.2.4.11 Patch available CNA
Remediation
- Fix · CNA Dell EMC NetWorker (Dell EMC) Fixed in 9.2.1.1, 9.1.1.6, 8.2.4.11
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1218
- 2026-10-03 Alias added: GHSA-pqq9-vjxp-gq39
References
Exploit 1
More Dell EMC vulnerabilities
- TI-2018-01128 Missing authorization in Dell EMC Avamar, Integrated Data Protection Appliance CVSS 3.0CRITICAL 9.8
- TI-2018-01141 OS command injection in Dell EMC RecoverPoint CVSS 3.0CRITICAL 9.8
- TI-2018-07852 Dell EMC Avamar and Integrated Data Protection Appliance Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2018-11243 Dell EMC ESRS Policy Manager versions 6.8 and prior contain a remote code execution… CVSS 3.0CRITICAL 9.8
- TI-2017-08041 OS command injection in Dell EMC Data Protection Advisor CVSS 3.1HIGH 8.8
Sources
- CVE-2018-1218 · CVE Program
- CVE-2018-1218 · NVD
- FIRST EPSS
- GHSA-pqq9-vjxp-gq39 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences