Read the docs
TI-2018-01143 Aliases CVE-2018-1238GHSA-wxf3-fg3q-j542

OS command injection in Dell EMC ScaleIO

Priority LOW 36CWE-78Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
High
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-78.

Summary

Dell EMC ScaleIO versions prior to 2.5, contain a command injection vulnerability in the Light Installation Agent (LIA). This component is used for central management of ScaleIO deployment and uses shell commands for certain actions. A remote malicious user, with network access to LIA and knowledge of the LIA administrative password, could potentially exploit this vulnerability to run arbitrary commands as root on the systems where LIAs are installed.

Why it matters now

EPSS 0.01493 74th percentileScored 2026-11-07
Fix Fixed ScaleIO (Dell EMC): 2.5

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Dell EMCScaleIObefore 2.52.5Patch availableCNA
  • ScaleIO VendorDell EMC Affected before 2.5 Fixed in 2.5 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:dell:emc_scaleio:*:*:*:*:*:*:*:*before 2.5VulnerableDell
  • cpe:2.3:a:dell:emc_scaleio:*:*:*:*:*:*:*:* Versions before 2.5 Vulnerable ·Dell

Remediation

  • Fix · CNA ScaleIO (Dell EMC) Fixed in 2.5

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-1238
  2. 2026-10-03 Alias added: GHSA-wxf3-fg3q-j542

References

  • TI-2018-01128 Missing authorization in Dell EMC Avamar, Integrated Data Protection Appliance CVSS 3.0CRITICAL 9.8
  • TI-2018-01141 OS command injection in Dell EMC RecoverPoint CVSS 3.0CRITICAL 9.8
  • TI-2018-07852 Dell EMC Avamar and Integrated Data Protection Appliance Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
  • TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
  • TI-2018-11243 Dell EMC ESRS Policy Manager versions 6.8 and prior contain a remote code execution… CVSS 3.0CRITICAL 9.8
  • TI-2017-08041 OS command injection in Dell EMC Data Protection Advisor CVSS 3.1HIGH 8.8
See all 96 →

Sources