Cross-site scripting in Dell EMC Unity
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Dell EMC Unity and UnityVSA contains reflected cross-site scripting vulnerability. A remote unauthenticated attacker could potentially exploit this vulnerability by tricking a victim application user to supply malicious HTML or Java Script code to Unisphere, which is then reflected back to the victim and executed by the web browser.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Dell EMC | Dell EMC Unity | before 4.3.1.1525703027 | 4.3.1.1525703027 | Patch available | CNA |
| Dell EMC | Dell EMC UnityVSA | before 4.3.1.1525703027 | 4.3.1.1525703027 | Patch available | CNA |
Remediation
- Fix · CNA Dell EMC Unity (Dell EMC) Fixed in 4.3.1.1525703027
- Fix · CNA Dell EMC UnityVSA (Dell EMC) Fixed in 4.3.1.1525703027
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Dell EMC Unity, Dell EMC UnityVSA 4.3.1.1525703027
3 records Highest priority Priority MEDIUM 1 MEDIUM, 2 LOW
Other records, highest priority first
- TI-2018-01156 Open redirect in Dell EMC UnityPriority MEDIUM 41
- TI-2018-01155 Incorrect authorization in Dell EMC UnityPriority LOW 32
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1246
- 2026-10-03 Alias added: GHSA-jp6c-fxpc-3qjr
References
More Dell EMC vulnerabilities
- TI-2018-01128 Missing authorization in Dell EMC Avamar, Integrated Data Protection Appliance CVSS 3.0CRITICAL 9.8
- TI-2018-01141 OS command injection in Dell EMC RecoverPoint CVSS 3.0CRITICAL 9.8
- TI-2018-07852 Dell EMC Avamar and Integrated Data Protection Appliance Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2017-05620 EMC Networker Remote Code Execution Vulnerability CVSS 3.0CRITICAL 9.8
- TI-2018-11243 Dell EMC ESRS Policy Manager versions 6.8 and prior contain a remote code execution… CVSS 3.0CRITICAL 9.8
- TI-2017-08041 OS command injection in Dell EMC Data Protection Advisor CVSS 3.1HIGH 8.8
Sources
- CVE-2018-1246 · CVE Program
- CVE-2018-1246 · NVD
- FIRST EPSS
- GHSA-jp6c-fxpc-3qjr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences