Code injection in Apache Kafka
Priority LOW 32CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- Partial Red Hat: 1 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-94.
Summary
In Apache Kafka 0.9.0.0 to 0.9.0.1, 0.10.0.0 to 0.10.2.1, 0.11.0.0 to 0.11.0.2, and 1.0.0, authenticated Kafka users may perform action reserved for the Broker via a manually created fetch request interfering with data replication, resulting in data loss.
Why it matters now
EPSS 0.04801 92nd percentileScored 2026-11-07
Fix Partial org.apache.kafka:kafka (Maven): 0.10.2.2, 0.11.0.3, 1.0.1Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Kafka | 0.9.0.0 to 0.9.0.1; 0.10.0.0 to 0.10.2.1; 0.11.0.0 to 0.11.0.2; 1.0.0 | — | No fix listed | CNA |
| — | org.apache.kafka:kafka (Maven) | 0.9.0.0 to before 0.10.2.2 | 0.10.2.2 | Patch available | GHSA-gh27-38p5-mrxc |
| — | org.apache.kafka:kafka (Maven) | 0.11.0.0 to before 0.11.0.3 | 0.11.0.3 | Patch available | GHSA-gh27-38p5-mrxc |
| — | org.apache.kafka:kafka (Maven) | 1.0.0 to before 1.0.1 | 1.0.1 | Patch available | GHSA-gh27-38p5-mrxc |
- Apache Kafka VendorApache Affected 0.9.0.0 to 0.9.0.1; 0.10.0.0 to 0.10.2.1; 0.11.0.0 to 0.11.0.2; 1.0.0 Fixed in — No fix listed CNA
- org.apache.kafka:kafka (Maven) Vendor— Affected 0.9.0.0 to before 0.10.2.2 Fixed in 0.10.2.2 Patch available GHSA-gh27-38p5-mrxc
- org.apache.kafka:kafka (Maven) Vendor— Affected 0.11.0.0 to before 0.11.0.3 Fixed in 0.11.0.3 Patch available GHSA-gh27-38p5-mrxc
- org.apache.kafka:kafka (Maven) Vendor— Affected 1.0.0 to before 1.0.1 Fixed in 1.0.1 Patch available GHSA-gh27-38p5-mrxc
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:* | after 0.9.0.0, up to 0.9.0.1; 0.10.0.0 – 0.10.2.1; 0.11.0.0 – 0.11.0.2 | Vulnerable | Apache |
| cpe:2.3:a:apache:kafka:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | Apache |
| cpe:2.3:a:redhat:jboss_middleware_text-only_advisories:1.0:*:*:*:*:middleware:*:* | 1.0 | Vulnerable | Red Hat |
| cpe:2.3:a:oracle:database:11.2.0.4:*:*:*:*:*:*:* | 11.2.0.4 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:database:12.1.0.2:*:*:*:*:*:*:* | 12.1.0.2 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:database:12.2.0.1:*:*:*:*:*:*:* | 12.2.0.1 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:database:18c:*:*:*:*:*:*:* | 18c | Vulnerable | Oracle |
| cpe:2.3:a:oracle:database:19c:*:*:*:*:*:*:* | 19c | Vulnerable | Oracle |
| cpe:2.3:a:oracle:primavera_p6_enterprise_project_portfolio_management:*:*:*:*:*:*:*:* | 19.12.0.0 – 19.12.6.0 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:timesten_in-memory_database:*:*:*:*:*:*:*:* | before 18.1.2.1.0 | Vulnerable | Oracle |
- cpe:2.3:a:apache:kafka:*:*:*:*:*:*:*:* Versions after 0.9.0.0, up to 0.9.0.1; 0.10.0.0 – 0.10.2.1; 0.11.0.0 – 0.11.0.2 Vulnerable ·Apache
- cpe:2.3:a:apache:kafka:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·Apache
- cpe:2.3:a:redhat:jboss_middleware_text-only_advisories:1.0:*:*:*:*:middleware:*:* Versions 1.0 Vulnerable ·Red Hat
- cpe:2.3:a:oracle:database:11.2.0.4:*:*:*:*:*:*:* Versions 11.2.0.4 Vulnerable ·Oracle
- cpe:2.3:a:oracle:database:12.1.0.2:*:*:*:*:*:*:* Versions 12.1.0.2 Vulnerable ·Oracle
- cpe:2.3:a:oracle:database:12.2.0.1:*:*:*:*:*:*:* Versions 12.2.0.1 Vulnerable ·Oracle
- cpe:2.3:a:oracle:database:18c:*:*:*:*:*:*:* Versions 18c Vulnerable ·Oracle
- cpe:2.3:a:oracle:database:19c:*:*:*:*:*:*:* Versions 19c Vulnerable ·Oracle
- cpe:2.3:a:oracle:primavera_p6_enterprise_project_portfolio_management:*:*:*:*:*:*:*:* Versions 19.12.0.0 – 19.12.6.0 Vulnerable ·Oracle
- cpe:2.3:a:oracle:timesten_in-memory_database:*:*:*:*:*:*:*:* Versions before 18.1.2.1.0 Vulnerable ·Oracle
Remediation
- Fix · GHSA-gh27-38p5-mrxc org.apache.kafka:kafka (Maven) Fixed in 0.10.2.2 Advisory →
- Fix · GHSA-gh27-38p5-mrxc org.apache.kafka:kafka (Maven) Fixed in 0.11.0.3 Advisory →
- Fix · GHSA-gh27-38p5-mrxc org.apache.kafka:kafka (Maven) Fixed in 1.0.1 Advisory →
Red Hat 1 advisory
- RHSA-2018:3768 Released 2018-12-04 · Red Hat rating ImportantRed Hat Fuse 7.2 security update
- Red Hat Fuse 7.2
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Application Runtimes | Affected | No fix planned: Will not fix |
| Red Hat Fuse 7.2 | Fixed | RHSA-2018:3768 |
Not affected: 2 products
- Red Hat JBoss Fuse 6
- Red Hat Mobile Application Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-1288
- 2026-10-03 Alias added: GHSA-gh27-38p5-mrxc
References
Other 14
- [kafka-users] 20180726 CVE-2018-1288: Authenticated Kafka clients may interfere with data replication
- [kafka-commits] 20190802 [kafka-site] branch asf-site updated: Add CVE-2018-17196, fix some links. (#223)
- [drill-dev] 20191017 Dependencies used by Drill contain known vulnerabilities
- [drill-dev] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
- [drill-issues] 20191021 [jira] [Created] (DRILL-7416) Updates required to dependencies to resolve potential security vulnerabilities
- [flink-issues] 20200402 [GitHub] [flink] zentol opened a new pull request #11617: [FLINK-16389][kafka] Bump kafka version to 0.10.2.2
- [kafka-dev] 20211007 Re: CVE Back Port?
- https://lists.apache.org/thread.html/29f61337323f48c47d4b41d74b9e452bd60e65d0e5103af9a6bb2fef@%3Cusers.kafka.apache.org%3E
- https://lists.apache.org/thread.html/519eb0fd45642dcecd9ff74cb3e71c20a4753f7d82e2f07864b5108f@%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/b0656d359c7d40ec9f39c8cc61bca66802ef9a2a12ee199f5b0c1442@%3Cdev.drill.apache.org%3E
- https://lists.apache.org/thread.html/d1581fb6464c9bec8a72575c01f5097d68e2fbb230aff24622622a58@%3Ccommits.kafka.apache.org%3E
- https://lists.apache.org/thread.html/f9bc3e55f4e28d1dcd1a69aae6d53e609a758e34d2869b4d798e13cc@%3Cissues.drill.apache.org%3E
- https://lists.apache.org/thread.html/r07e1bbd1643847d599feb34c707906a4fdcc81e3a6ab01a10c451d40@%3Cissues.flink.apache.org%3E
- https://lists.apache.org/thread.html/r35322aec467ddae34002690edaa4d9f16e7df9b5bf7164869b75b62c@%3Cdev.kafka.apache.org%3E
More Apache Kafka vulnerabilities
- TI-2025-20589 Apache Kafka Client: Arbitrary file read and SSRF vulnerability CVSS 3.1HIGH 7.5
- TI-2026-25947 Apache Kafka: Missing JWT token validation in OAUTHBEARER authentication CVSS 3.1CRITICAL 9.1
- TI-2018-12295 Improper input validation in Apache Kafka CVSS 3.0HIGH 8.8
- TI-2025-20590 Apache Kafka: Possible RCE attack via SASL JAAS LdapLoginModule configuration CVSS 3.1HIGH 8.8
- TI-2022-15706 Unauthenticated clients may cause OutOfMemoryError on Apache Kafka Brokers CVSS 3.1HIGH 7.5
- TI-2025-20591 Apache Kafka: Possible RCE/Denial of service attack via SASL JAAS JndiLoginModule configuration CVSS 3.1HIGH 7.5
Sources
- CVE-2018-1288 · CVE Program
- CVE-2018-1288 · NVD
- FIRST EPSS
- GHSA-gh27-38p5-mrxc · GitHub Advisory Database · CC BY 4.0
- CVE-2018-1288 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences