Cross-site scripting in HackerOne connect node module
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
connect node module before 2.14.0 suffers from a Cross-Site Scripting (XSS) vulnerability due to a lack of validation of file in directory.js middleware.
Why it matters now
EPSS 0.01306 70th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed connect node module (HackerOne): 2.14.0connect (npm): 2.14.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | connect node module | before 2.14.0 | 2.14.0 | Patch available | CNA |
| — | connect (npm) | before 2.14.0 | 2.14.0 | Patch available | GHSA-rch9-xh7r-mqgw |
- connect node module VendorHackerOne Affected before 2.14.0 Fixed in 2.14.0 Patch available CNA
- connect (npm) Vendor— Affected before 2.14.0 Fixed in 2.14.0 Patch available GHSA-rch9-xh7r-mqgw
Remediation
- Fix · CNA connect node module (HackerOne) Fixed in 2.14.0
- Fix · GHSA-rch9-xh7r-mqgw connect (npm) Fixed in 2.14.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Mobile Application Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2018-3717
- 2026-10-03 Alias added: GHSA-rch9-xh7r-mqgw
References
Advisory 2
More Sencha Connect vulnerabilities
- TI-2013-06035 Cross-site scripting in node-connect CVSS 3.1MEDIUM 6.1
- TI-2013-06034 node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware CVSS 3.1MEDIUM 6.1
- TI-2013-04113 Sencha Labs Connect has XSS with connect.methodOverride() CVSS 3.1MEDIUM 6.1
Sources
- CVE-2018-3717 · CVE Program
- CVE-2018-3717 · NVD
- FIRST EPSS
- GHSA-rch9-xh7r-mqgw · GitHub Advisory Database · CC BY 4.0
- CVE-2018-3717 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences