Improper input validation in Atlassian Bamboo
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA.
Summary
Bamboo did not correctly check if a configured Mercurial repository URI contained values that the Windows operating system may consider argument parameters. An attacker who has permission to create a repository in Bamboo, edit an existing plan in Bamboo that has a non-linked Mercurial repository, or create a plan in Bamboo either globally or in a project using Bamboo Specs can can execute code of their choice on systems that run a vulnerable version of Bamboo on the Windows operating system. All versions of Bamboo starting with 2.7.0 before 6.3.3 (the fixed version for 6.3.x) and from version 6.4.0 before 6.4.1 (the fixed version for 6.4.x) running on the Windows operating system are affected by this vulnerability.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Atlassian | Bamboo | 2.7.1 and later; before 6.3.3; 6.4.0 and later; before 6.4.1 | 6.3.3, 6.4.1 | Patch available | CNA |
- Bamboo VendorAtlassian Affected 2.7.1 and later; before 6.3.3; 6.4.0 and later; before 6.4.1 Fixed in 6.3.3, 6.4.1 Patch available CNA
Remediation
- Fix · CNA Bamboo (Atlassian) Fixed in 6.3.3, 6.4.1
Timeline
- 2026-10-02 Threatist record created from CVE-2018-5224
- 2026-10-03 Alias added: GHSA-5h5c-rh7j-pwpg
References
More Atlassian Bamboo vulnerabilities
- TI-2026-67904 Arbitrary file access in Atlassian Data Center products KEVCVSS 4.0CRITICAL 9.3
- TI-2012-02540 Atlassian JIRA before 5.0.1; Confluence before 3.5.16, 4.0 before 4.0.7, and 4.1 before… CVSS 3.1CRITICAL 9.1
- TI-2022-09598 Improper authentication in Atlassian Bamboo Server CVSS 3.1CRITICAL 9.8
- TI-2016-04529 Atlassian Bamboo before 5.11.4.1 and 5.12.x before 5.12.3.1 does not properly restrict… CVSS 3.0CRITICAL 9.8
- TI-2015-06881 An unspecified resource in Atlassian Bamboo before 5.9.9 and 5.10.x before 5.10.0 allows… CVSS 3.0CRITICAL 9.8
- TI-2014-07936 The Ignite Realtime Smack XMPP API, as used in Atlassian Bamboo before 5.9.9 and 5.10.x… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2018-5224 · CVE Program
- CVE-2018-5224 · NVD
- FIRST EPSS
- GHSA-5h5c-rh7j-pwpg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences