Read the docs
TI-2018-04790 Aliases CVE-2018-6510GHSA-m8f8-29g4-v3cr

XSS Vulnerability in Puppet Enterprise Console

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

A cross-site scripting vulnerability in Puppet Enterprise Console of Puppet Enterprise allows a user to inject scripts into the Puppet Enterprise Console when using the Orchestrator. Affected releases are Puppet Puppet Enterprise: 2017.3.x versions prior to 2017.3.6.

Why it matters now

EPSS 0.00508 43rd percentileScored 2026-11-07
Fix Fixed Puppet Enterprise (Puppet): 2017.3.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
PuppetPuppet Enterprise2017.3.x to before 2017.3.62017.3.6Patch availableCNA
  • Puppet Enterprise VendorPuppet Affected 2017.3.x to before 2017.3.6 Fixed in 2017.3.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:*before 2017.3.6VulnerablePuppet
  • cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions before 2017.3.6 Vulnerable ·Puppet

Remediation

  • Fix · CNA Puppet Enterprise (Puppet) Fixed in 2017.3.6

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Puppet Enterprise 2017.3.6

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2018-04791 XSS Vulnerability in Puppet Enterprise ConsolePriority LOW 25

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-6510
  2. 2026-10-03 Alias added: GHSA-m8f8-29g4-v3cr

References

  • TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
  • TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
  • TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
  • TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
  • TI-2016-02330 MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote… CVSS 3.0CRITICAL 9.8
  • TI-2021-08596 A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP… CVSS 3.1CRITICAL 9.8
See all 88 →

Sources