XSS Vulnerability in Puppet Enterprise Console
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A cross-site scripting vulnerability in Puppet Enterprise Console of Puppet Enterprise allows a user to inject scripts into the Puppet Enterprise Console when using the Puppet Enterprise Console. Affected releases are Puppet Puppet Enterprise: 2017.3.x versions prior to 2017.3.6.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA Puppet Enterprise (Puppet) Fixed in 2017.3.6
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Puppet Enterprise 2017.3.6
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2018-04790 XSS Vulnerability in Puppet Enterprise ConsolePriority LOW 25
Timeline
- 2026-10-02 Threatist record created from CVE-2018-6511
- 2026-10-03 Alias added: GHSA-r37h-jc5q-gg43
- 2026-10-16 EPSS moved to the 50th–90th percentile
- 2026-10-18 EPSS moved to the below the 50th percentile
- 2026-10-25 EPSS moved to the 50th–90th percentile
References
More Puppet Enterprise vulnerabilities
- TI-2017-05170 Integer overflow in nginx CVSS 3.1HIGH 7.5
- TI-2023-02371 A privilege escalation allowing remote code execution was discovered in the orchestration service. CVSS 3.1CRITICAL 9.8
- TI-2013-01442 The (1) template and (2) inline_template functions in the master server in Puppet before… CVSS 2.0HIGH 9.0
- TI-2018-04792 Code injection in Puppet Enterprise 2018.1.x prior to 2018.1.1, razor-server and… CVSS 3.0CRITICAL 9.8
- TI-2016-02330 MCollective 2.7.0 and 2.8.x before 2.8.9, as used in Puppet Enterprise, allows remote… CVSS 3.0CRITICAL 9.8
- TI-2021-08596 A flaw was discovered in Puppet Agent and Puppet Server that may result in a leak of HTTP… CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-6511 · CVE Program
- CVE-2018-6511 · NVD
- FIRST EPSS
- GHSA-r37h-jc5q-gg43 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences