Google TensorFlow 1.7.x and earlier is affected by a Buffer Overflow vulnerability.
Priority MEDIUM 43CWE-190Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-190 and the CVSS impact.
Summary
Google TensorFlow 1.7.x and earlier is affected by a Buffer Overflow vulnerability. The type of exploitation is context-dependent.
Why it matters now
EPSS 0.00634 50th percentileScored 2026-11-07
Fix Fixed tensorflow (PyPI): 1.7.1tensorflow-gpu (PyPI): 1.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | tensorflow (PyPI) | 1.0.0 to before 1.7.1 | 1.7.1 | Patch available | GHSA-mw6v-crh8-8533 |
| — | tensorflow-gpu (PyPI) | 1.0.0 to before 1.7.1 | 1.7.1 | Patch available | GHSA-mw6v-crh8-8533 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- tensorflow (PyPI) Vendor— Affected 1.0.0 to before 1.7.1 Fixed in 1.7.1 Patch available GHSA-mw6v-crh8-8533
- tensorflow-gpu (PyPI) Vendor— Affected 1.0.0 to before 1.7.1 Fixed in 1.7.1 Patch available GHSA-mw6v-crh8-8533
Remediation
- Fix · GHSA-mw6v-crh8-8533 tensorflow (PyPI) Fixed in 1.7.1 Advisory →
- Fix · GHSA-mw6v-crh8-8533 tensorflow-gpu (PyPI) Fixed in 1.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-7575
- 2026-10-03 Alias added: GHSA-mw6v-crh8-8533
- 2026-11-07 EPSS moved to the 50th–90th percentile
References
Patch 1
Advisory 2
Other 5
- https://github.com/tensorflow/tensorflow/commit/d107fee1e4a9a4462f01564798d345802acc2aef
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-223.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-230.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-205.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2018-7575 · CVE Program
- CVE-2018-7575 · NVD
- FIRST EPSS
- GHSA-mw6v-crh8-8533 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences