Google TensorFlow 1.7 and below is affected by: Buffer Overflow.
Priority LOW 39CWE-119Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-119 and the CVSS impact.
Summary
Google TensorFlow 1.7 and below is affected by: Buffer Overflow. The impact is: execute arbitrary code (local).
Why it matters now
EPSS 0.00751 55th percentileScored 2026-11-07
Fix Fixed tensorflow (PyPI): 1.7.1tensorflow-gpu (PyPI): 1.7.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | tensorflow (PyPI) | 1.5.0 to before 1.7.1 | 1.7.1 | Patch available | GHSA-frxx-2m33-6wcr |
| — | tensorflow-gpu (PyPI) | 1.5.0 to before 1.7.1 | 1.7.1 | Patch available | GHSA-frxx-2m33-6wcr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- tensorflow (PyPI) Vendor— Affected 1.5.0 to before 1.7.1 Fixed in 1.7.1 Patch available GHSA-frxx-2m33-6wcr
- tensorflow-gpu (PyPI) Vendor— Affected 1.5.0 to before 1.7.1 Fixed in 1.7.1 Patch available GHSA-frxx-2m33-6wcr
Remediation
- Fix · GHSA-frxx-2m33-6wcr tensorflow (PyPI) Fixed in 1.7.1 Advisory →
- Fix · GHSA-frxx-2m33-6wcr tensorflow-gpu (PyPI) Fixed in 1.7.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-8825
- 2026-10-03 Alias added: GHSA-frxx-2m33-6wcr
References
Patch 1
Advisory 2
Other 6
- https://github.com/tensorflow/tensorflow/commit/41335abb46f80ca644b5738550daef6136ba5476
- https://github.com/tensorflow/tensorflow/commit/8badd11d875a826bd318ed439909d5c47a7fb811
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-226.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-233.yaml
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-208.yaml
- https://github.com/tensorflow/tensorflow
More Google Tensorflow vulnerabilities
- TI-2022-20241 FractionalMaxPool and FractionalAVGPool heap out-of-bounds acess in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07640 Integer overflow in Tensorflow CVSS 3.1CRITICAL 9.8
- TI-2022-07627 Out of bounds read and write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07619 Out of bounds write in Tensorflow CVSS 3.1HIGH 8.8
- TI-2022-07613 Read and Write outside of bounds in TFLite CVSS 3.1HIGH 8.8
- TI-2022-07612 Integer overflow in TFLite CVSS 3.1HIGH 8.8
Sources
- CVE-2018-8825 · CVE Program
- CVE-2018-8825 · NVD
- FIRST EPSS
- GHSA-frxx-2m33-6wcr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences