Cross-site scripting (XSS) vulnerability in lib/interface.php of the Relevanssi plugin…
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in lib/interface.php of the Relevanssi plugin 4.0.4 for WordPress allows remote attackers to inject arbitrary JavaScript or HTML via the tab GET parameter.
Why it matters now
EPSS 0.01901 79th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2018-9034
- 2026-10-03 Alias added: GHSA-xmfw-pc9f-89cm
References
Exploit 1
More comesio Relevanssi vulnerabilities
- TI-2023-06585 Relevanssi (Free < 4.22.0, Premium < 2.25.0) - Unauthenticated Private/Draft Post Disclosure CVSS 3.1MEDIUM 5.3
- TI-2024-01287 Missing authorization in comesio Relevanssi Premium CVSS 3.1MEDIUM 5.3
- TI-2024-08374 Relevanssi < 4.23.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2024-03012 Relevanssi – A Better Search <= 4.22.1 - Unauthenticated Second Order CSV Injection CVSS 3.1CRITICAL 9.8
- TI-2024-03011 Relevanssi – A Better Search <= 4.22.1 - Missing Authorization to Unauthenticated Count Option Update CVSS 3.1HIGH 8.2
- TI-2016-08987 The Relevanssi Premium plugin before 1.14.6.1 for WordPress has SQL injection with resultant unsafe unserialization. CVSS 3.1HIGH 8.8
Sources
- CVE-2018-9034 · CVE Program
- CVE-2018-9034 · NVD
- FIRST EPSS
- GHSA-xmfw-pc9f-89cm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences