Priority MEDIUM 63
The Relevanssi WordPress plugin before 4.22.0, Relevanssi Premium WordPress plugin before 2.25.0 allows any unauthenticated user to read draft and private posts via a crafted request
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00616 · Published 2024-01-29 · Fixed in 4.22.0, 2.25.0 CWE-639
Priority MEDIUM 61
The Relevanssi – A Better Search plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the relevanssi_export_log_check() function in all versions up to, and including, 4.2…
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.50192 · Published 2024-03-13 · No fix listed CWE-862
Priority MEDIUM 58
In the process of testing the Relevanssi WordPress plugin before 4.23.1, a vulnerability was found that allows you to implement Stored XSS on behalf of the Contributor+ by embedding malicious script, which entails accoun…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00451 · Published 2024-10-08 · Fixed in 4.23.1 CWE-79
Priority MEDIUM 50
The Relevanssi – A Better Search plugin for WordPress is vulnerable to CSV Injection in all versions up to, and including, 4.22.1.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.00769 · Published 2024-04-09 · No fix listed CWE-1236
Priority MEDIUM 44
The Relevanssi – A Better Search plugin for WordPress is vulnerable to time-based SQL Injection via the cats and tags query parameters in all versions up to, and including, 4.24.4 (Free) and <= 2.27.5 (Premium) due to in…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.02697 · Published 2025-05-13 · No fix listed CWE-89
Priority MEDIUM 43
The Relevanssi – A Better Search plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the relevanssi_update_counts() function in all versions up to, and including,…
CVSS 3.1HIGH 8.2· Network · No auth · No interaction · EPSS 0.0081 · Published 2024-04-09 · No fix listed CWE-862
Priority MEDIUM 41
The Relevanssi Premium plugin before 1.14.6.1 for WordPress has SQL injection with resultant unsafe unserialization.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.01577 · Published 2019-09-13 · No fix listed CWE-89
Priority LOW 39
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 4.22.2 (Free) and 2.25.1 (Premium) via the relevanssi_do_query() due to insufficient limit…
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.00478 · Published 2024-08-16 · No fix listed CWE-200
Priority LOW 31
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 4.28.5 due to insufficient input sanitization and outpu…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00247 · Published 2026-10-31 · No fix listed CWE-79
Priority LOW 31
The Relevanssi Premium plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the '_rt' parameter in all versions up to, and including, 2.31.4 due to insufficient input sanitization and output escaping.
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00231 · Published 2026-10-02 · No fix listed CWE-79
Priority LOW 31
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Comment Content in all versions up to, and including, 4.28.3 due to insufficient input sanitization and output escapi…
CVSS 3.1HIGH 7.2· Network · No auth · No interaction · EPSS 0.00241 · Published 2026-10-02 · No fix listed CWE-79
Priority LOW 30
The Relevanssi Live Ajax Search plugin for WordPress is vulnerable to argument injection in all versions up to, and including, 2.4.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00419 · Published 2024-08-28 · No fix listed CWE-88
Priority LOW 29
The plugin provides an Admin Search page that allows users with the `edit_posts` capability to run Relevanssi searches from the WordPress dashboard.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00413 · Published 2026-08-05 · No fix listed CWE-89
Priority LOW 29
WordPress plugin Relevanssi version 3.5.7.1 is vulnerable to stored XSS resulting in attacker being able to execute JavaScript on the affected site
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.0106 · Published 2017-07-13 · No fix listed CWE-79
Priority LOW 28
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 4.28.1 via the 's', 'post_types', and 'orderby' request parameters.
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00461 · Published 2026-09-11 · No fix listed CWE-79
Priority LOW 28
Cross-site scripting (XSS) vulnerability in lib/interface.php of the Relevanssi plugin 4.0.4 for WordPress allows remote attackers to inject arbitrary JavaScript or HTML via the tab GET parameter.
CVSS 3.0MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.01901 · Published 2018-04-04 · No fix listed CWE-79
Priority LOW 28
Reflected XSS in Relevanssi Premium version 1.14.8 when using relevanssi_didyoumean() could allow unauthenticated attacker to do almost anything an admin can
CVSS 3.0MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00723 · Published 2017-11-17 · No fix listed CWE-79
Priority LOW 27
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the highlights functionality in all versions up to, and including, 4.24.3 (Free) and <= 2.27.4 (Premium), due to insu…
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.00411 · Published 2025-05-07 · No fix listed CWE-79
Priority LOW 23
Cross-site scripting (XSS) vulnerability in the Relevanssi plugin before 3.3.8 for WordPress allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
CVSS 2.0MEDIUM 4.3· Network · No auth · Interaction — · EPSS 0.01601 · Published 2015-01-02 · No fix listed CWE-79
Priority LOW 21
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Excerpt Highlights in all versions up to, and including, 4.24.5 (Free) and 2.27.6 (Premium) due to insufficient i…
CVSS 3.1MEDIUM 4.7· Network · No auth · User interaction · EPSS 0.00234 · Published 2025-05-31 · No fix listed CWE-79