Relevanssi < 4.23.1 - Contributor+ Stored XSS
Priority MEDIUM 58CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
In the process of testing the Relevanssi WordPress plugin before 4.23.1, a vulnerability was found that allows you to implement Stored XSS on behalf of the Contributor+ by embedding malicious script, which entails account takeover backdoor
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00451 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Relevanssi (Unknown): 4.23.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Relevanssi | before 4.23.1 | 4.23.1 | Patch available | CNA |
- Relevanssi VendorUnknown Affected before 4.23.1 Fixed in 4.23.1 Patch available CNA
Remediation
- Fix · CNA Relevanssi (Unknown) Fixed in 4.23.1
Timeline
- 2026-10-02 Threatist record created from CVE-2024-9021
- 2026-10-03 Alias added: GHSA-h3fm-h666-8g3f
References
More comesio Relevanssi vulnerabilities
- TI-2023-06585 Relevanssi (Free < 4.22.0, Premium < 2.25.0) - Unauthenticated Private/Draft Post Disclosure CVSS 3.1MEDIUM 5.3
- TI-2024-01287 Missing authorization in comesio Relevanssi Premium CVSS 3.1MEDIUM 5.3
- TI-2024-03012 Relevanssi – A Better Search <= 4.22.1 - Unauthenticated Second Order CSV Injection CVSS 3.1CRITICAL 9.8
- TI-2024-03011 Relevanssi – A Better Search <= 4.22.1 - Missing Authorization to Unauthenticated Count Option Update CVSS 3.1HIGH 8.2
- TI-2016-08987 The Relevanssi Premium plugin before 1.14.6.1 for WordPress has SQL injection with resultant unsafe unserialization. CVSS 3.1HIGH 8.8
- TI-2024-07072 Relevanssi <= 4.22.2 (Free) and <= 2.25.1 (Premium) - Unauthenticated Information Exposure CVSS 3.1HIGH 7.5
Sources
- CVE-2024-9021 · CVE Program
- CVE-2024-9021 · NVD
- FIRST EPSS
- GHSA-h3fm-h666-8g3f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences