Information disclosure in [UNKNOWN] moodle
Priority LOW 28CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. It was possible for the core_course_get_categories web service to return hidden categories, which should be omitted when fetching course categories.
Why it matters now
EPSS 0.02052 81st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.1.13, 3.3.7, 3.4.4 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | moodle | moodle 3.5.1; moodle 3.4.4; moodle 3.3.7; moodle 3.1.13 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.1 to before 3.1.13 | 3.1.13 | Patch available | GHSA-5w4h-xrr5-7273 |
| — | moodle/moodle (Packagist) | 3.3 to before 3.3.7 | 3.3.7 | Patch available | GHSA-5w4h-xrr5-7273 |
| — | moodle/moodle (Packagist) | 3.4 to before 3.4.4 | 3.4.4 | Patch available | GHSA-5w4h-xrr5-7273 |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.1 | 3.5.1 | Patch available | GHSA-5w4h-xrr5-7273 |
- moodle Vendor[UNKNOWN] Affected moodle 3.5.1; moodle 3.4.4; moodle 3.3.7; moodle 3.1.13 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.13 Fixed in 3.1.13 Patch available GHSA-5w4h-xrr5-7273
- moodle/moodle (Packagist) Vendor— Affected 3.3 to before 3.3.7 Fixed in 3.3.7 Patch available GHSA-5w4h-xrr5-7273
- moodle/moodle (Packagist) Vendor— Affected 3.4 to before 3.4.4 Fixed in 3.4.4 Patch available GHSA-5w4h-xrr5-7273
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.1 Fixed in 3.5.1 Patch available GHSA-5w4h-xrr5-7273
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.1.0 to before 3.1.13; 3.3.0 to before 3.3.7; 3.4.0 to before 3.4.4; 3.5.0 to before 3.5.1 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.1.0 to before 3.1.13; 3.3.0 to before 3.3.7; 3.4.0 to before 3.4.4; 3.5.0 to before 3.5.1 Vulnerable ·Moodle
Remediation
- Fix · GHSA-5w4h-xrr5-7273 moodle/moodle (Packagist) Fixed in 3.1.13 Advisory →
- Fix · GHSA-5w4h-xrr5-7273 moodle/moodle (Packagist) Fixed in 3.3.7 Advisory →
- Fix · GHSA-5w4h-xrr5-7273 moodle/moodle (Packagist) Fixed in 3.4.4 Advisory →
- Fix · GHSA-5w4h-xrr5-7273 moodle/moodle (Packagist) Fixed in 3.5.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-10890
- 2026-10-03 Alias added: GHSA-5w4h-xrr5-7273
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2018-10890 · CVE Program
- CVE-2018-10890 · NVD
- FIRST EPSS
- GHSA-5w4h-xrr5-7273 · GitHub Advisory Database · CC BY 4.0
- CVE-2018-10890 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences