Read the docs
TI-2018-07704 Aliases CVE-2018-10891GHSA-p7v9-gjrh-563x

Improper input validation in [UNKNOWN] moodle

Priority LOW 36CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.

Summary

A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. When a quiz question bank is imported, it was possible for the question preview that is displayed to execute JavaScript that is written into the question bank.

Why it matters now

EPSS 0.02064 81st percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.5.1, 3.4.4, 3.3.7 +2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]moodlemoodle 3.5.1; moodle 3.4.4; moodle 3.3.7; moodle 3.1.13—No fix listedCNA
—moodle/moodle (Packagist)3.5.0 to before 3.5.13.5.1Patch availableGHSA-p7v9-gjrh-563x
—moodle/moodle (Packagist)3.4.0 to before 3.4.43.4.4Patch availableGHSA-p7v9-gjrh-563x
—moodle/moodle (Packagist)3.3.0 to before 3.3.73.3.7Patch availableGHSA-p7v9-gjrh-563x
—moodle/moodle (Packagist)3.2.0 to before 3.2.103.2.10Patch availableGHSA-p7v9-gjrh-563x
—moodle/moodle (Packagist)3.1.0 to before 3.1.133.1.13Patch availableGHSA-p7v9-gjrh-563x
  • moodle Vendor[UNKNOWN] Affected moodle 3.5.1; moodle 3.4.4; moodle 3.3.7; moodle 3.1.13 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.5.0 to before 3.5.1 Fixed in 3.5.1 Patch available GHSA-p7v9-gjrh-563x
  • moodle/moodle (Packagist) Vendor— Affected 3.4.0 to before 3.4.4 Fixed in 3.4.4 Patch available GHSA-p7v9-gjrh-563x
  • moodle/moodle (Packagist) Vendor— Affected 3.3.0 to before 3.3.7 Fixed in 3.3.7 Patch available GHSA-p7v9-gjrh-563x
  • moodle/moodle (Packagist) Vendor— Affected 3.2.0 to before 3.2.10 Fixed in 3.2.10 Patch available GHSA-p7v9-gjrh-563x
  • moodle/moodle (Packagist) Vendor— Affected 3.1.0 to before 3.1.13 Fixed in 3.1.13 Patch available GHSA-p7v9-gjrh-563x

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*3.1 to before 3.1.13; 3.3 to before 3.3.7; 3.4 to before 3.4.4; 3.5 to before 3.5.1VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.1 to before 3.1.13; 3.3 to before 3.3.7; 3.4 to before 3.4.4; 3.5 to before 3.5.1 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-p7v9-gjrh-563x moodle/moodle (Packagist) Fixed in 3.5.1 Advisory →
  • Fix · GHSA-p7v9-gjrh-563x moodle/moodle (Packagist) Fixed in 3.4.4 Advisory →
  • Fix · GHSA-p7v9-gjrh-563x moodle/moodle (Packagist) Fixed in 3.3.7 Advisory →
  • Fix · GHSA-p7v9-gjrh-563x moodle/moodle (Packagist) Fixed in 3.2.10 Advisory →
  • Fix · GHSA-p7v9-gjrh-563x moodle/moodle (Packagist) Fixed in 3.1.13 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-10891
  2. 2026-10-03 Alias added: GHSA-p7v9-gjrh-563x

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources