Read the docs
TI-2018-10495 Aliases CVE-2018-14630GHSA-c3pr-h96w-2jjg

Improper input validation in [UNKNOWN] moodle

Priority MEDIUM 45CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.

Summary

moodle before versions 3.5.2, 3.4.5, 3.3.8, 3.1.14 is vulnerable to an XML import of ddwtos could lead to intentional remote code execution. When importing legacy 'drag and drop into text' (ddwtos) type quiz questions, it was possible to inject and execute PHP code from within the imported questions, either intentionally or by importing questions from an untrusted source.

Why it matters now

EPSS 0.04604 91st percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed moodle/moodle (Packagist): 3.5.2, 3.4.5, 3.3.8 +1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
[UNKNOWN]moodle3.5.2; 3.4.5; 3.3.8; 3.1.14—No fix listedCNA
—moodle/moodle (Packagist)3.5.0 to before 3.5.23.5.2Patch availableGHSA-c3pr-h96w-2jjg
—moodle/moodle (Packagist)3.4.0 to before 3.4.53.4.5Patch availableGHSA-c3pr-h96w-2jjg
—moodle/moodle (Packagist)3.2.0 to before 3.3.83.3.8Patch availableGHSA-c3pr-h96w-2jjg
—moodle/moodle (Packagist)before 3.1.143.1.14Patch availableGHSA-c3pr-h96w-2jjg
  • moodle Vendor[UNKNOWN] Affected 3.5.2; 3.4.5; 3.3.8; 3.1.14 Fixed in — No fix listed CNA
  • moodle/moodle (Packagist) Vendor— Affected 3.5.0 to before 3.5.2 Fixed in 3.5.2 Patch available GHSA-c3pr-h96w-2jjg
  • moodle/moodle (Packagist) Vendor— Affected 3.4.0 to before 3.4.5 Fixed in 3.4.5 Patch available GHSA-c3pr-h96w-2jjg
  • moodle/moodle (Packagist) Vendor— Affected 3.2.0 to before 3.3.8 Fixed in 3.3.8 Patch available GHSA-c3pr-h96w-2jjg
  • moodle/moodle (Packagist) Vendor— Affected before 3.1.14 Fixed in 3.1.14 Patch available GHSA-c3pr-h96w-2jjg

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*up to 3.0.10; 3.1.0 to before 3.1.14; 3.3.0 to before 3.3.8; 3.4.0 to before 3.4.5; 3.5.0 to before 3.5.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 3.0.10; 3.1.0 to before 3.1.14; 3.3.0 to before 3.3.8; 3.4.0 to before 3.4.5; 3.5.0 to before 3.5.2 Vulnerable ·Moodle

Remediation

  • Fix · GHSA-c3pr-h96w-2jjg moodle/moodle (Packagist) Fixed in 3.5.2 Advisory →
  • Fix · GHSA-c3pr-h96w-2jjg moodle/moodle (Packagist) Fixed in 3.4.5 Advisory →
  • Fix · GHSA-c3pr-h96w-2jjg moodle/moodle (Packagist) Fixed in 3.3.8 Advisory →
  • Fix · GHSA-c3pr-h96w-2jjg moodle/moodle (Packagist) Fixed in 3.1.14 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2018-14630
  2. 2026-10-03 Alias added: GHSA-c3pr-h96w-2jjg

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources