Improper input validation in [UNKNOWN] moodle
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
moodle before versions 3.5.2, 3.4.5, 3.3.8 is vulnerable to a boost theme - blog search GET parameter insufficiently filtered. The breadcrumb navigation provided by Boost theme when displaying search results of a blog were insufficiently filtered, which could result in reflected XSS if a user followed a malicious link containing JavaScript in the search parameter.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | moodle | 3.5.2; 3.4.5; 3.3.8 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.3 to before 3.3.8 | 3.3.8 | Patch available | GHSA-gqrp-qhv8-phrv |
| — | moodle/moodle (Packagist) | 3.4 to before 3.4.5 | 3.4.5 | Patch available | GHSA-gqrp-qhv8-phrv |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.2 | 3.5.2 | Patch available | GHSA-gqrp-qhv8-phrv |
- moodle Vendor[UNKNOWN] Affected 3.5.2; 3.4.5; 3.3.8 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.3 to before 3.3.8 Fixed in 3.3.8 Patch available GHSA-gqrp-qhv8-phrv
- moodle/moodle (Packagist) Vendor— Affected 3.4 to before 3.4.5 Fixed in 3.4.5 Patch available GHSA-gqrp-qhv8-phrv
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.2 Fixed in 3.5.2 Patch available GHSA-gqrp-qhv8-phrv
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | 3.3.0 to before 3.3.8; 3.4.0 to before 3.4.5; 3.5.0 to before 3.5.2 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 3.3.0 to before 3.3.8; 3.4.0 to before 3.4.5; 3.5.0 to before 3.5.2 Vulnerable ·Moodle
Remediation
- Fix · GHSA-gqrp-qhv8-phrv moodle/moodle (Packagist) Fixed in 3.3.8 Advisory →
- Fix · GHSA-gqrp-qhv8-phrv moodle/moodle (Packagist) Fixed in 3.4.5 Advisory →
- Fix · GHSA-gqrp-qhv8-phrv moodle/moodle (Packagist) Fixed in 3.5.2 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-14631
- 2026-10-03 Alias added: GHSA-gqrp-qhv8-phrv
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2018-14631 · CVE Program
- CVE-2018-14631 · NVD
- FIRST EPSS
- GHSA-gqrp-qhv8-phrv · GitHub Advisory Database · CC BY 4.0
- CVE-2018-14631 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences