Cross-site request forgery in [UNKNOWN] moodle
Priority MEDIUM 43CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
A flaw was found in moodle versions 3.5 to 3.5.2, 3.4 to 3.4.5, 3.3 to 3.3.8, 3.1 to 3.1.14 and earlier. The login form is not protected by a token to prevent login cross-site request forgery. Fixed versions include 3.6, 3.5.3, 3.4.6, 3.3.9 and 3.1.15.
Why it matters now
EPSS 0.02326 83rd percentileScored 2026-11-07
Fix Fixed moodle/moodle (Packagist): 3.1.15, 3.3.9, 3.4.6 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| [UNKNOWN] | moodle | 3.6; 3.5.3; 3.4.6; 3.3.9; 3.1.15 | — | No fix listed | CNA |
| — | moodle/moodle (Packagist) | 3.1 to before 3.1.15 | 3.1.15 | Patch available | GHSA-xj5f-qv37-r9jc |
| — | moodle/moodle (Packagist) | 3.3 to before 3.3.9 | 3.3.9 | Patch available | GHSA-xj5f-qv37-r9jc |
| — | moodle/moodle (Packagist) | 3.4 to before 3.4.6 | 3.4.6 | Patch available | GHSA-xj5f-qv37-r9jc |
| — | moodle/moodle (Packagist) | 3.5 to before 3.5.3 | 3.5.3 | Patch available | GHSA-xj5f-qv37-r9jc |
- moodle Vendor[UNKNOWN] Affected 3.6; 3.5.3; 3.4.6; 3.3.9; 3.1.15 Fixed in — No fix listed CNA
- moodle/moodle (Packagist) Vendor— Affected 3.1 to before 3.1.15 Fixed in 3.1.15 Patch available GHSA-xj5f-qv37-r9jc
- moodle/moodle (Packagist) Vendor— Affected 3.3 to before 3.3.9 Fixed in 3.3.9 Patch available GHSA-xj5f-qv37-r9jc
- moodle/moodle (Packagist) Vendor— Affected 3.4 to before 3.4.6 Fixed in 3.4.6 Patch available GHSA-xj5f-qv37-r9jc
- moodle/moodle (Packagist) Vendor— Affected 3.5 to before 3.5.3 Fixed in 3.5.3 Patch available GHSA-xj5f-qv37-r9jc
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* | up to 3.0.10; 3.1.0 to before 3.1.15; 3.3.0 to before 3.3.9; 3.4.0 to before 3.4.6; 3.5.0 to before 3.5.3 | Vulnerable | Moodle |
- cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions up to 3.0.10; 3.1.0 to before 3.1.15; 3.3.0 to before 3.3.9; 3.4.0 to before 3.4.6; 3.5.0 to before 3.5.3 Vulnerable ·Moodle
Remediation
- Fix · GHSA-xj5f-qv37-r9jc moodle/moodle (Packagist) Fixed in 3.1.15 Advisory →
- Fix · GHSA-xj5f-qv37-r9jc moodle/moodle (Packagist) Fixed in 3.3.9 Advisory →
- Fix · GHSA-xj5f-qv37-r9jc moodle/moodle (Packagist) Fixed in 3.4.6 Advisory →
- Fix · GHSA-xj5f-qv37-r9jc moodle/moodle (Packagist) Fixed in 3.5.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2018-16854
- 2026-10-03 Alias added: GHSA-xj5f-qv37-r9jc
References
More Moodle vulnerabilities
- TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
- TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
- TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
- TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
- TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
- TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
Sources
- CVE-2018-16854 · CVE Program
- CVE-2018-16854 · NVD
- FIRST EPSS
- GHSA-xj5f-qv37-r9jc · GitHub Advisory Database · CC BY 4.0
- CVE-2018-16854 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences