Cross-site scripting in Apache Syncope
Priority LOW 27CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A malicious user with enough administration entitlements can inject html-like elements containing JavaScript statements into Connector names, Report names, AnyTypeClass keys and Policy descriptions. When another user with enough administration entitlements edits one of the Entities above via Admin Console, the injected JavaScript code is executed.
Why it matters now
EPSS 0.01204 68th percentileScored 2026-11-07
Fix Fixed org.apache.syncope:syncope-core (Maven): 2.0.11, 2.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Syncope | Apache Syncope releases prior to 2.0.11 and 2.1.2 | — | No fix listed | CNA |
| — | org.apache.syncope:syncope-core (Maven) | before 2.0.11 | 2.0.11 | Patch available | GHSA-9h9c-f287-c6vp |
| — | org.apache.syncope:syncope-core (Maven) | 2.1.0 to before 2.1.2 | 2.1.2 | Patch available | GHSA-9h9c-f287-c6vp |
- Apache Syncope VendorApache Affected Apache Syncope releases prior to 2.0.11 and 2.1.2 Fixed in — No fix listed CNA
- org.apache.syncope:syncope-core (Maven) Vendor— Affected before 2.0.11 Fixed in 2.0.11 Patch available GHSA-9h9c-f287-c6vp
- org.apache.syncope:syncope-core (Maven) Vendor— Affected 2.1.0 to before 2.1.2 Fixed in 2.1.2 Patch available GHSA-9h9c-f287-c6vp
Remediation
- Fix · GHSA-9h9c-f287-c6vp org.apache.syncope:syncope-core (Maven) Fixed in 2.0.11 Advisory →
- Fix · GHSA-9h9c-f287-c6vp org.apache.syncope:syncope-core (Maven) Fixed in 2.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-17184
- 2026-10-03 Alias added: GHSA-9h9c-f287-c6vp
References
More Apache Syncope vulnerabilities
- TI-2025-35632 Apache Syncope: Remote Code Execution by delegated administrators CVSS 3.1HIGH 7.2
- TI-2026-38503 Apache Syncope: Remote Code Execution via Scripted Connector CVSS 3.1CRITICAL 9.8
- TI-2026-45025 Apache Syncope: RCE via Groovy Sandbox bypass CVSS 3.1CRITICAL 9.8
- TI-2026-44406 Apache Syncope: User self-service privilege escalation CVSS 3.1CRITICAL 9.8
- TI-2026-41245 Apache Syncope: SQL injection vulnerability in Audit Events search CVSS 3.1CRITICAL 9.8
- TI-2026-38491 Apache Syncope: Remote Code Execution via Flowable BPMN Groovy ScriptTask CVSS 3.1CRITICAL 9.8
Sources
- CVE-2018-17184 · CVE Program
- CVE-2018-17184 · NVD
- FIRST EPSS
- GHSA-9h9c-f287-c6vp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences