Shopware before 5.4.3 allows SQL Injection by remote authenticated users, aka SW-21404.
Priority MEDIUM 40CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
Shopware before 5.4.3 allows SQL Injection by remote authenticated users, aka SW-21404.
Why it matters now
EPSS 0.01107 66th percentileScored 2026-11-07
Fix Fixed shopware/shopware (Packagist): 5.4.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | shopware/shopware (Packagist) | before 5.4.3 | 5.4.3 | Patch available | GHSA-42gv-77f4-r3j9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- shopware/shopware (Packagist) Vendor— Affected before 5.4.3 Fixed in 5.4.3 Patch available GHSA-42gv-77f4-r3j9
Remediation
- Fix · GHSA-42gv-77f4-r3j9 shopware/shopware (Packagist) Fixed in 5.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-20713
- 2026-10-03 Alias added: GHSA-42gv-77f4-r3j9
References
More Shopware vulnerabilities
- TI-2023-01895 Improper Control of Generation of Code in Twig Rendered Views in Shopware CVSS 3.1HIGH 8.8
- TI-2025-20623 Shopware prior to version 6.5.8.13 is affected by a SQL injection vulnerability in the… CVSS 3.1MEDIUM 6.8
- TI-2024-28343 Shopware vulnerable to Server Side Template Injection in Twig using Context functions CVSS 3.1HIGH 8.3
- TI-2019-09582 In createInstanceFromNamedArguments in Shopware through 5.6.x, a crafted web request can… CVSS 3.1HIGH 8.8
- TI-2016-02607 The backend/Login/load/ script in Shopware before 5.1.5 allows remote attackers to execute arbitrary code. CVSS 3.0CRITICAL 9.8
- TI-2025-32365 A stored cross-site scripting (XSS) vulnerability exists in the Shopware 6 installation… CVSS 3.1MEDIUM 6.1
Sources
- CVE-2018-20713 · CVE Program
- CVE-2018-20713 · NVD
- FIRST EPSS
- GHSA-42gv-77f4-r3j9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences