Home Assistant before 0.67.0 was vulnerable to an information disclosure that allowed an…
Priority LOW 36CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Home Assistant before 0.67.0 was vulnerable to an information disclosure that allowed an unauthenticated attacker to read the application's error log via components/api.py.
Why it matters now
EPSS 0.01739 77th percentileScored 2026-11-07
Fix Fixed homeassistant (PyPI): 0.67.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | homeassistant (PyPI) | before 0.67.0 | 0.67.0 | Patch available | GHSA-mh78-8f49-vjg3 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- homeassistant (PyPI) Vendor— Affected before 0.67.0 Fixed in 0.67.0 Patch available GHSA-mh78-8f49-vjg3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:home-assistant:home-assistant:*:*:*:*:*:*:*:* | before 0.67.0 | Vulnerable | home-assistant |
- cpe:2.3:a:home-assistant:home-assistant:*:*:*:*:*:*:*:* Versions before 0.67.0 Vulnerable ·home-assistant
Remediation
- Fix · GHSA-mh78-8f49-vjg3 homeassistant (PyPI) Fixed in 0.67.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2018-21019
- 2026-10-03 Alias added: GHSA-mh78-8f49-vjg3
References
Advisory 2
Other 5
- https://github.com/home-assistant/core/pull/13836
- https://github.com/home-assistant/core/commit/598f093bf0fecdefaa3d95d1ddae71317a05321e
- https://github.com/home-assistant/core
- https://github.com/home-assistant/core/releases/tag/0.67.0
- https://github.com/pypa/advisory-database/tree/main/vulns/homeassistant/PYSEC-2019-221.yaml
More Home-assistant vulnerabilities
- TI-2023-12210 Improper authentication in home-assistant core CVSS 3.1CRITICAL 10.0
- TI-2026-25491 Home Assistant has stored XSS in history-graphs CVSS 4.0HIGH 7.3
- TI-2026-25490 Home Assistant has stored XSS in Map-card through malicious device name CVSS 4.0HIGH 7.3
- TI-2026-39212 Home Assistant: Konnected alarm-panel switch state and zone topology disclosed to unauthenticated actors on the LAN CVSS 3.1HIGH 7.6
- TI-2025-40423 Home Assistant Core before v2025.8.0 is vulnerable to Directory Traversal. CVSS 3.1MEDIUM 4.0
- TI-2023-22289 Lack of XFO header allows clickjacking in Home Assistant Core CVSS 3.1CRITICAL 9.6
Sources
- CVE-2018-21019 · CVE Program
- CVE-2018-21019 · NVD
- FIRST EPSS
- GHSA-mh78-8f49-vjg3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences